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1 Xlpd Manual

The manual describe how to use the program's interface and will guide you through the basics.
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3 About Xlpd

Xlpd is a remote printer server program that enables printing of remote files with a PC printer in a network
enviornment configured via Internet or LAN. Several computers in a network can share a single printer connected to
a server via a printer server program .

Xlpd eliminates the complicated process of having to download files from a remote UNIX/Linux system to a PC to
print them. When you are connected to a remote UNIX/Linux system with Xmanager or Xshell, and want to print
some data in the remote system, just enter the print command on the terminal prompt.

3.1 Key Functions

Supports LPD Protocol (RFC 1179)
LPD protocol defined in RFC 1179 uses TCP port No. 515. For details, see 'LPD Protocol'.

Windows Service Mode

Xlpd can run as a Windows service or an independent program. When run as Windows service, Xlpd processes all
printing jobs with a default queue without the user log in through their individual accounts. It is also convenient
because service automatically starts when Windows starts. In this case, run or exit actions in the main Xlpd window
do not affect Xlpd service execution and ending.

Supports Multi-queue
Since multi-queue is supported, different printers can be used or different printing methods can be designated by
queue.

Printer Setup
A printer for file printing can be designated for each queue.

Printing with and without formatting
For text files, Xlpd provides formatting concerning font, spacing and etc. For details, see 'Print by Formatting Text
File'. For PS (PostScript) or PCL (Printer Command Lanaguge) files, the direct printing must be used.

CRLF Conversion
Xlpd provides a function to convert CR (Carriage Return) to CRLF (Carriage Return & Line Feed) for successful
printing of UNIX system text documents in a Windows environment.

Jobs List Window to View Printing Status
The status of each process can be checked from reception of a requested printing job to actual printing.

Print Job Processing (delete, print, store)
Xlpd provides functions to save or delete a print job.

Processes LPQ/LPSTAT Command
Xlpd receives and processes the LPQ and LPSTAT commands requested by UNIX system.

LPD Port Change
In addition to the general LPD port 515, other ports can be used according to user setting.

Log Viewer to View Error and Job Processing Details
Xlpd provides a log viewer to view details of job processing or errors. Log viewer provides search functions by
period, queue, and message type.

Run in Windows Notification Area
Xlpd runs in the Windows notification area even if the main window is closed.
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3.2 LPD Protocol

The LPD (Line Printer Daemon) is the most general printing protocol used in the TCP/IP network environment. LPD
uses the TCP protocol and its default port is No. 515. In a UNIX system, a user requests a print job using an lp, lpr or
pr command, and the job will be sent to your PC over the network. The LPD in action receives the request and prints
on a printer connected to a PC according to the options and settings.

3.3 Recommendations

« Processor: Compatible with Intel’

« Operating System:Microsoft Windows' Vista or higher
« Storage Space: Reserve space of 100MB or more
Network: TCP/IP network

.

3.4 Install and Uninstall

The Xlpd install program can be downloaded from http://www.netsarang.com/.

The install program was generated using InstallShield®, and various options can be changed during installation. It is
sufficient in most cases to simply click [Next]. To uninstall Xlpd, use standard Windows add/remove features . Run
[Add/Remove Program] and select in the control panel to uninstall Xlpd from the list.

Even when the program is uninstalled, the registry information, log files and user generated data files are not
removed. Such information and files are available for reuse when the program is reinstalled. Delete all the registry
information and files from the following location:

Registry Information:

« \HKEY_CURRENT_USER\Software\NetSarang\Xlpd
File and Folder:

+ "User's Docuements Folder"\Netsarang Computer\7\Xlpd
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4 Start

This section provides descriptions on starting Xlpd, queue management, printer setup, file printing and closing
Xlpd.

4.1 StartXlpd

Xlpd can be divided into Xlpd service, which receives and processes print jobs and Xlpd main window, capable of
handling print jons and queues. Depending on user choice, service can be run as Windows service or as
independent program.

1. RunXlpd.

When Xlpd is executed, the main Xlpd window opens and, if in independent mode, Xlpd service starts at the same
time.

Note

When Xlpd is run for the first time, the default Windows printer is used as the printer for the default queue. If
a default printer does not exist, a printer must be registered. If another program is already operating with
TCP 515, a message indicating that the port is being used by another program is displayed.

4.2 Close and Open Xlpd Main Window

To Close the Xlpd Main Window

1. Select [Exit] in the [File] menu. A notification area icon is generated when [Close Button Action] is set as
[Minimize to the notification area] in the Options dialog box.

To Open the Xlpd Main Window

1. Point to the Xlpd icon in the notification area.
2. Right-click on the icon and select [Open].

To Avoid Minimizing to the Notification Area

1. Select [Options]in the [Tools] menu.
2. Set [Close Button Action] as [Exit Xlpd].
3. Click [OK] to save change.

4.3 Queue Management

Xlpd supports multi-queue. Each queue uses different printing methods or can be assigned to different printers.
To Add a New Queue

Click the [File] menu.

Select [New Queue].

When the Add a new queue dialog box is displayed, enter a name for the new queue.
Adjust the necessary options in the dialog box.

Click [OK].

Note
If [Use Default queue for unknown queue request] is not set in the Options dialog box, a new queue is
automatically added when a printing request is made to a queue that is not registered to Xlpd.

o

To Delete a Queue

1. Select the queue which is to be deleted from the list of queues.
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2. Select [Delete Queue] from the [File] menu.

Note
A queue set as the default queue cannot be deleted.

To Change Queue Properties

1. Select the queue whose properties needs to be changed, from the list of queues.
2. Select [Properties] from the [Queue] menu.
3. Adjust the necessary options in the Queue Properties dialog box.

4.4 Print from Remote Host

Set a remote printer by referring to 'Remote Printer Setup'.

After printer setup, the remote host makes a printing command as follows, in order to print a text file "test.txt":
$ lpr —Pserver test.txt

Or

$ lpr —dserver test.txt

Note

Printing command varies slightly by host type. See printer setup and printer commands by host in 'Remote
Printer Setup'.

4.5 End Xlpd and Stop Windows Service

« Select [Exit] from the [File] menu.

« If an option has been set to minimize the notification area, right-click on the Xlpd notification area icon and
select [Exit].

« If Xlpd is run in Windows service mode, open Services from the Administrative Tools section in Control
Panel. And then, find the Xlpd Service and click on Stop Service in the toolbar..
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5 Remote Printer Setup

It is difficult for a general user to set a remote printer; nigh impossible at times due to issues relating to UNIX/Linux
system permisson. In this case, you need to consult with your system administrator to set up a printer on the
remote host.

See the NetSarang Inc. website for UNIX/Linux descriptions which are not available in this manual.

5.1 General Setup

The general remote printer registration settings are as outlined below.

Register IP Address of a PC, Printer Server

Add the IP address and host name of the PC where Xlpd is installed, to the /etc/hosts file of the UNIX host:
192.168.1.119 lpd_pc_name

« Aspaceisrequired between the IP address and host name.
Remote Printer Setup Terminologies

« Printer Name The name of a printer to be registered in UNIX. A file is sent for printing under this name. In
some UNIX systems, this printer name becomes the queue name if there is no separate option to set a queue
name.

« Printer Server Refers to the host name or IP address of the PC where Xlpd is installed. Some systems only
require a host name.

+ Queue Name A Xlpd (Printer Server) queue name is designated. Xlpd carries out printing tasks by receiving
queue names from the client. The queue names must match in order to print files with the queues registered
in Xlpd.

General Printer Registration Guidelines

+ Select [Berkeley] or [BSD] in print type. Xlpd supports LPD protocol and this is generally referred to as
Berkeley remote printing protocol.

« In Berkeley UNIX system, refer to the printcap manual page to register a printer:
$ man printcap

« To printfiles, the lpr command can be run as follows. In addition, the print menu can be used in some
document editors. For I[pr command options, see the manual page.
$ lpr -PPrinter_name filename
or
$ lpr -dPrinter_name filename

5.2 Solaris Printer Setup

Run admintool in console and register a remote printer in the following order.
Solaris 2.6, Solaris 8, Solaris 9, Solaris 10

1. Run /usr/bin/admintool with root permissions.
2. Click [Browse] -> [Printers] in menu.
3. Click [Add] -> [Access to Printer] in the [Edit] menu.
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4. Enterinformation as follows in the printer setup screen:
I Admintool: Add Access To Printer

Print Client: sparc

Printer Name: | #lpd

Print Setver: | mypc

Description: | Laser Printer

Option: _| Default Printer

OK | apply | Reset| cancel| Help |

Fig. 1: Solaris printer setup

+ Printer Name: Name designated when printing a file with the lpr command. To print a file under
a queue name registered in Xlpd, the queue name must be the same as that of Xlpd. If the queue
name is not registered in Xlpd, print a file with the default queue according to Xlpd settings or
by generating a new queue.

« Print Server: Enter the host name of a PC with Xlpd installed. As described in 'General Setup', the
host name must be registered in the /etc/hosts file.

« Description: Enter remote printer information, such as printer model. This item is not used at the
printing command.

« Option - Default Printer: When this item is checked, the printer registered becomes a default
printer, designated as a default at the printing command. When the printer is omitted from the
command, the file is printed by the default printer.

5. Click [OK] to exit admintool.
6. The command to print a file in Solaris is as follows: $ /usr/ucb/lpr -PPrinter_name filename

5.3 HP UX Printer Setting

Set printer by running sam after login to root.

1. With root permissions, run /usr/bin/sam or /usr/sbin/sam.
2. Run by double clicking [Printers and Plotters] -> [LPSpooler] -> [Printers/Plotters] in order.
3. Click [Actions] -> [Add remote Printer/Plotter...] in the menu.
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Enter the following in the printer setup screen:

Frinter Name:

Remote Svstem Name: 19 1.188

Remote Printer Name: Qname

Remote Cancel Model... romodel

Remote Status Model... rsmodel

Default Regquest Priority:

=

=

0K Cancel

Fig. 2: HP printer setup

Printer Name: Enter the name of a printer to be designated for printing.

Remote System Name: Enter the name or IP address of a PC with Xlpd installed. In some cases, the program
may not be installed with the IP address. In such case, enter the PC name after registering the name in /etc/
hosts file as described in 'General Setup'.

Remote Printer Name: Enter the queue name registered in Xlpd. If the queue name is not registered in
Xlpd, print a file with the default queue according to the Xlpd settings or by generating a new queue.
Remote Printer is on a BSD system: This item must be checked.

Leave the rest as defaults.

Click [OK] to end sam.

The command to print a file in HP UX 10.x is as follows: $ /usr/bin/lpr -dPrinter_name filename

AIX Printer Setup

AIX 4.x, AIX 5.x

1.
2.

Run /usr/bin/smit with root permissions.
Click [Print Spooling] -> [AIX Print Spooling] -> [Add a Print Queue]) -> [remote: Remote Printer Attached to
Remote Host] -> [Standard Processing] in order.
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3. Enter the following in the printer setup screen:

* Mame of QUEUE on remo jar | queusd
TYPE of print on remot ar BSD List IA_ IT

s KW

Command

Fig. 3: AIX printer setup

» Name of QUEUE to add: The name of the printer designated for printing.

« HOSTNAME of remote server: Enter the IP address name of a PC with Xlpd installed. In some cases,
the program may not be installed with an IP address. In such case, enter the PC name after
registering it in the /etc/hosts file as described in 'General Setup'.

+ Name of QUEUE on remote server: Enter the queue name used in Xlpd. If the queue name is not
registered in Xlpd, print a file with the default queue according to the Xlpd settings or by generating
anew queue.

« TYPE of print spooler on remote server: Be sure to select BSD.

- Backend TIME OUT period(minutes)(Num.): Use default value.

+ Send control file first?: Use default value.

« To turn on debugging, specify output file pathname: Use default value.

« DESCRIPTION of printer on remote server: Enter remote printer information, such as printer
model. This item is not used for the printing command.

4. Click [OK] to end smit.

. Thefile print command in AIX 4.x or AIX 5.x is as follows: $ /usr/bin/lpr -PPrinter_name filename

6. If the error message "unable to run gdaemon" is shown during setup, run the following command as root
user.: # /usr/sbin/qdaemon&

(63}

5.5 IRIX Printer Setup

. Runtoolchest with root permissions.

. Click [Printer Manager] in system menu.

. Double click [Add].

. Enter [Printer name].

. Select [Network for remote printers].

. Enter name or IP address of a PC with Xlpd installed in [Remote Host Name].
. Click [OK].

~No b WNR
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5.6 SCO UNIX Printer Setup

. Run scoadmin with root permissions.

. Click [Printers].

. Click [Printer Manager].

. Click [Printer/Add Remote/UNIX].

. Enter PC host name and printer name.

. Be certain not to select [Use extended remote printing protocol].
. Click [OK].

~NoO b WNR

5.7 RedHat Linux Printer Setup

RedHat Enterprise Linux 4.x, 5.x

1. Run /usr/sbin/system-config-printer with root permissions. For remote execution, run in a PC X server, such
as Xmanager.
2. Click [Add a new printer] to proceed with installation according to the screen instructions.

:

Printer Name

May contain any printable characters except /", "#", and space

o |

Description (opticnal)
Human-readable description such as "HP Laser]et with Duplexer"

[ l

Location (optional)

Human-readable location such as "Lab 1"

[ l

Fig. 4: RedHat Enterprise Linux printer setup 1

+ Printer Name: Name designated when printing a file with the lpr command or in a Linux application
program.

« Description (optional): Enter remote printer information, such as printer model. This item is not used at the
printing command.

+ Location (optional): Enter remote printer location. This item is not used at the printing command.
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Select Connection Location of the LPD network printer
Devices Hostname

BT 192168171 [~ ]

Serial Port #1 Printername
AppSocket/HP JetDirect [ dpd_redhat | = l

Bluetooth printer

Internet Printing Protocol (ipp)

LPD/LPR Host or Printer

Windows Printer via SAMBA
Other

4 Back ” ¥ Cancel ”E & Forward l

Fig. 5: RedHat Enterprise Linux printer setup 2

+ Devices: Select [LPD/LPR Host or Printer].

« Hostname: Enter the name or IP address of a PC with Xlpd installed.

« Printername: Xlpd queue name. Xlpd generates a queue using this name. Printing can be processed with
the default queue without generating a queue according to Xlpd settings.

(@ iSelect Printer from database;

The foomatic printer database contains various manufacturer provided PostScript Printer
Description (PPD) files and also can generate PPD files for a large number of (non
PostScript) printers. But in general manufacturer provided PPD files provide better access
to the specific features of the printer.

Makes

Alps

() Provide PPD file

PostScript Printer Description (PPD) files can often found on the driver disk that comes with
the printer. For PostScript printers they are often part of the Windows® driver.

l 4@ Back H ¥ Cancel H & Forward

Fig. 6: RedHat Enterprise Linux printer setup 3

« Select Printer from database: Select Xlpd connected printer model. If model does not exist, select a printer
compatible with the printer concerned. Initially, UNIX/Linux application program supported PostScript only.
Recently however, PCL printer language has also been supported. Check compatibility of model to use and
select compatible printer in the Generic printer section.
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1. Click [Apply] to complete printer registration.
2. The command to print a file in RedHat Enterprise Linux is as follows: $ /usr/bin/lpr -Pprinter_name filename
ex) $ /usr/bin/lpr -Pxlpd /etc/hosts
RedHat Linux 9.x, Redhat Enterprise Linux 3.x

1. Run /usr/sbin/printtool or /usr/bin/redhat-config-printer with root permissions.
2. Click [Add (a new printer)] and proceed with installation according to the screen instructions.

st s o B ==
Queue name

Please enter a name for this queue. Choose a short
name that begins with a letter and contains no spaces.

Name: | |
About

If you like, you can enter a description of the printer
to help you identify it more easily.

Short description: | |

& Help 32 Cancel < Back > Forward

Fig. 7: RedHat Linux printer setup 1

» Queue Name: Printer name designated when printing a file with the lpr command or in Linux application
program.

« Short Description: Enter information to give a brief description of the printer. This is optional.

st s o B ==
Queue type

Select a queue type: | Networked UNIX (LPD) st ‘
Server; Queue:
192.168.1.87 Bipd_redna
& Help 32 cancel <] Back > Forward

Fig. 8: RedHat Linux printer setup 2

+ Select Queue Type: Select [Network Linked UNIX (LPD)].
« Server: Enter the IP address name of an Xlpd installed PC.

+ Queue: This is the Xlpd queue name. Xlpd generates a queue using this name. Printing can be processed
with the default queue without generating a queue according to Xlpd settings.
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= B

Printer model

Select the printer manufacturer and model. Depending
on how the remote queue is configured, you may need

to select the generic PostScript option here.

| Generic (click to select manufacturer)
48 pin

9-pin 136 Col

9-pin 80 Col

PostScript Printer

& Help 32 cancel < Back > Forward

Fig. 10: RedHat Linux printer setup 3

+ Printer Model: Select Xlpd connected printer model. If model does not exist, select a printer compatible
with the printer concerned. Initially, UNIX/Linux application program supported PostScript only. Recently,
however, PCL printer language has also been supported. Check compatibility of model to use and select
compatible printer in the Generic printer section.

1. Click [Apply] to complete printer registration.
2. Command to print a file in RedHat 7.x, 8.x, 9.x is as follows: $ /usr/bin/lpr -Pqueue_name filename ex) $ /usr/
bin/lpr -Pxlpd /etc/hosts

5.8 Fedora Printer Setup

FedoraCore1l,2,3,4,5

1. Run /usr/bin/redhat-config-printer or /usr/bin/system-config-printer with root permissions. For remote
execution, run in a PC X server, such as Xmanager.
2. Forinstallation process, see 'RedHat Linux 9.x, Redhat Enterprise Linux 3.x.'
FedoraCore 6, Fedora 7

1. Run /usr/sbin/system-config-printer with root permissions. For remote execution, run in a PC X server, such

as Xmanager.
2. Forinstallation process, see 'RedHat Enterprise Linux 4.x, 5.x."

Fedora 8,9, 10,11,12,13, 14

1. Run /usr/sbin/system-config-printer with root permissions. For remote execution, run in a PC X server, such

as Xmanager.
2. Click [Add a new printer] and proceed with installation according to the screen instructions.
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Select Connection Location of the LPD network printer

Devices Hostname

LPT #1 1192.168.1.87 | v || @ probe

Serial Port #1 Printername

Serial Port #2 [ipd fedora | ]
Windows Printer via SAMBA
AppSocket/HP JetDirect
Internet Printing Protocol (ipp)

LPD/LPR Host or Printer

Other

Fig. 9: Fedora Linux printer setup 1

« Devices: Select [LPD/LPR Host or Printer].
« Hostname: Enter name or IP address of a PC with Xlpd installed.
+ Printername: The Xlpd queue name. Xlpd generates a queue using this name. Printing can be processed

with the default queue without generating a queue according to Xlpd settings.

@ Select Printer from database!

The foomatic printer database contains various manufacturer provided PostScript Printer
Description (PPD] files and also can generate PPD files for a large number of (non
PostScript) printers. But in general manufacturer provided PPD files provide better access
to the specific features of the printer.

Alps

W S 1%

) Provide PPD file
PostScript Printer Description (PPD) files can often found on the driver disk that comes
with the printer. For PostScript printers they are often part of the Windows® driver.

l 4EBack H € cancel H »Ecrwardl

Fig. 10: Fedora Linux printer setup 2

+ Select Printer from database: Select Xlpd connected printer model. If model does not exist, select a printer
compatible with the printer concerned. Initially, UNIX/Linux application program supported PostScript only.
Recently, however, PCL printer language has also been supported. Check compatibility of model to use and
select compatible printer in the Generic printer section.
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[ k]
% Mew Printer ‘ ‘ @

Printer Name

May contain any printable characters except "/, "#", and space
pd

Description (optional)

Human-readable description such as "HP Laser]et with Duplexer”

Location (optional)
Human-readable location such as "Lab 1"

Fedora8-x64-L101222

IL «Eack agancel *Eorward

Fig. 11: Fedora Linux printer setup 3

+ Printer Name: Name designated when printing a file with the lpr command or in a Linux application
program.

 Description (optional): Enter remote printer information, such as printer mode. This item is not used at the
printing command.

+ Location (optional): Enter information about remote printer location. This item is not used at the printing
command.

1. Click [Apply] to complete printer registration.
2. Command to print a file in RedHat Enterprise Linux is as follows: § /usr/bin/lpr -Pprinter_name filename ex)
$ Jusr/bin/lpr -Pxlpd /etc/hosts

5.9 CentOS Printer Setup

CentOS 4.x

1. Run /usr/sbin/printtool or /usr/sbin/system-config-printer with root permissions. For remote execution, run
in a PC X server, such as Xmanager.
2. Forinstallation process, see 'RedHat Linux 9.x, Redhat Enterprise Linux 3.x."

CentOS 5.x

1. Run /usr/sbin/system-config-printer with root permissions. For remote execution, run in a PC X server, such
as Xmanager.
2. Forinstallation process, see 'RedHat Enterprise Linux 4.x, 5.x'.

5.10 Ubuntu Printer Setup

Ubuntu 9.x, 10.x

1. Run /usr/sbin/system-config-printer with root permissions. For remote execution, run in a PC X server, such
as Xmanager.
2. Forinstallation process, see 'Fedora 8,9, 10, 11,12, 13, 14'.
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5.11 SuSE Linux Printer Setup

SuSE Linux 10.x, SuSE Linux Enterprise 10.x, 11.x, OpenSuSE 10.x, 11.x

1. Run /sbin/yast with root permissions.

Select [Hardware] -> [Printer].

Select [Add] in [Printers and Queues].

Select [Network Printers] for [Printer Type]. (This process may be omitted according to 0S.)
Select [Print via LPD-Style Network Server] for [Network Printers].

Accurately enter information necessary for the following description in the printer setting screen:

oA W

Forwarding Queue to a Remote LPD

Connection Information
Hostname of Print Server
192 _.168.1.87 .[Look up | 1f]|
Remote Queue Hame

[Test Remote LPD Access]

[Help] [Back] [Abort] [Hext]

Fig. 12: OpenSuSE 11 printer setup 1

« Hostname of Printer Server: Enter the name or IP address of a PC with Xlpd installed.
+ Remote Queue Name: Xlpd queue name. Xlpd generates a queue using this name. Printing may be
processed with the default queue without generating a queue according to Xlpd settings.
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Queue Hame

Queue Mame and Spooler Settings
Mame for Printing

Printer Description
Printer Location
[¥] Share Printer

[ 1 Do Local Filtering

[Help] [Back] [Abort] [Hext]

Fig. 13: OpenSuSE 11 printer setup 2

« Name for printing: Printer name to be designated when printing a file in SuSE Linux. This information must
be entered.

« Printer Description: Enter remote printer information, such as printer model. This item is not used at
printing command.

« Printer Location: Enter information about the remote printer location. This item is not used at printing
command.

+ Share Printer: Select when intending to share printer via the network.

+ Do Local Filtering: Do not check as it is not used at the LPD printing command.

SuSE Linux 9.0

1. Run/sbin/yast with root permissions.

Click [Hardware] -> [Printer].

Click [Configure] in [Printer setup].

Click [Print via LPD-Style Network Server] for [Printer Type].

N
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5. Accurately enter information necessary for the description below in the printer setting screen:

Forwarding gqueue to a remote LPD
Host Name:

ommection information
Remote queue: Host i

[Test remote LPD accessl

[Backl [Abort 1

Fig. 14: SuSE 9.0 printer setup 1

Queue name
Name for Printing:
ueue name and spooler settings
Name for printing:

Description of Printer
Description of
Printer:

[ 1 Do Local Filtering
Location of
Printer: [ 1 Automatically Propose Multiple Queues

Local Filtering: [Test printingl
Do Local

[Backl [Abort ]

Fig. 15: SuSE 9.0 printer setup 2

+ Hostname of the printer server: Enter IP address name of a PC with Xlpd installed. In some cases,
the program may not be installed with an IP address. In such case, be sure to enter the PC name after
registering it in /etc/hosts file.

+ Name of the remote queue: Enter the name of queue used in Xlpd. If the queue name is not
registered in Xlpd, print a file with the default queue according to Xlpd settings or by generating a
new queue.

+ Name for printing: Printer name to be designated when printing a file with a printer. This
information must be entered.

+ Description of Printer: Enter remote printer information, such as printer model. This item is not
used at printing command.
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+ Location of Printer: Enter information about remote printer location. This item is not used at

printing command.
+ Do Local Filtering: Do not check as it is not applicable to a local printer.
+ Automatically Propose Multiple Queues: Do not check as it is not used at the LPD printing

command.
6. Click [Next] -> [Finish], save settings and exit program.
7. Command to print afile in this OS is as follows. For details, see man page: $ /usr/bin/lpr -Pprinter_name

filename

5.12 Windows 2000_XP_2003_Vista_7 Printer Setup

1. Run [Add Printer Wizard] in the course of implementing [Add Printer].
2. Besureto select [Local Printer] in a screen asking for [Local or Network Printer (wireless, Bluetooth)]. and

then click [Next]. The Choose a Printer Port step appears.
=X

=
Q f=  Add Printer

Choose a printer port

A printer port is a type of connection that allows your computer to exchange information with a
printer.

() Use an existing port: LPFT1: (Frinter Port)

(@ Create a new port:

Type of port: Standard TCP/IF Port -

[ Mext ][ Cancel

he

Fig. 16: Windows Add printer wizard, Choose a printer port
Select [Create a new port].

Select [Standard TCP/IP Port].

5. Click [Next].

> w
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6. Enter the necessary information in the step of typing a printer hostname or IP a
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@ g Add Printer

S

h

Type a printer hostname or [P address

Device type: [Autodetect
Hostname or IP address: 192,168, 1. 100
Port name: Xlpd

Query the printer and automatically select the driver to use

[ MNext ][ Cancel l

ddress:

Fig. 17: Windows Add t printer wizard, Type a printer hostname or IP address
« Printer Name or IP Address: Enter the IP address name of a PC with Xlpd installed.

» Port Name: Enter an intrinsic name. It is okay to enter an automatically generated name when the
above printer name is entered.

7. Click [Next]. The Additional Port Information Required step appears.

@ i Add Printer

h

Additional Port Information Required

The device is not found on the networke. Be sure that:

. The device is tumed on.

1
2. The network
3

is connected.

. The device is propery configured.
4. The address on the previous page is comect.

if you think the address is not comect, click Back to retum to the previous page. Then comect
the address and perform another search on the network. f you are sure the address is comect,

select the device type below.

Device Type
() Standard

@ Custom

Generic Metwork Card

MNext ][ Cancel

Fig. 18: Windows Add printer wizard, stage 2
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8. §elect [Custom] and click [Settings]. Configure Standard TCP/IP Port Monitor dialog box is displayed .

Configure Standard TCF/IP Port Monitor

E=)

Port Settings

Port Name:

Printer Mame or IP Address:

Protocol
" Raw

Raw Settings

|><1pd

|152.1EB.1.1DD

* LPR

|=:1::

LPR Settings

Gueue Mame: |Queue

v 1 PR Byte Counting Enabled:

[~ SMMP Status Enabled

|1

[

0K

] l Cancel

Fig. 19: Configure Standard TCP/IP Port Monitor

« Protocol: Be sure to select LPR.

+ LPR Settings - Queue Name: Enter the name of a queue used in Xlpd. If the name is not registered in
Xlpd, print a file with the default queue or by generating a new queue according to Xlpd settings.

+ LPR Settings - LPR Byte Counting Enabled: Be sure to check this.

« SNMP Status Enabled: Be sure this is not checked.

9. Click [OK] in the dialog box above to complete the add port wizard.
10. Complete the remaining add printer wizard process and exit the add printer wizard.
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6 Xlpd Settings

The settings necessary to operate Xlpd can be changed in the Options dialog box.

6.1 Change LPD Port

LPD uses the TCP protocol, and its default port number is 515. The port number can be adjusted if the port is
already in use by another program, or when required by remote host LPR client settings.

1. Click [Options] in the [Tools] menu. Options dialog box is displayed.
2. Enterthe required LPD portin [Port].
3. Click [OK].

6.2 Alert Window on Error

When Xlpd is run, an icon is generated in the notification area. Xlpd does not close and stands by for printing even
when the main window is closed. If an error occurs during action, the user must be notified immediately.

1. Click [Options] in the [Tools] menu. Options dialog box is displayed.
2. Check [Show an alert window when an error occurs].
3. Click [OK].

6.3 Close Button Action Settings

Even when Xlpd is closed via [File] - [Exit], an icon is generated in the notification area according to the options. To
completely end Xlpd, set the [Exit X|pd] option.

1. Click [Options] in the [Tool] menu. Options dialog box is displayed.
2. Select the [Exit Xlpd] in [Close Button Action].
3. Click [OK].

6.4 Run Xlpd as Windows Service

When set to operate Xlpd as Windows service, printing tasks are processed in the corresponding queues even if no
user logs in with a specific user account.

1. Click [Options] in the [Tools] menu. Options dialog box is displayed.
2. Check [Run as Windows service].
3. Click [OK].

6.5 Previewing Print Job

Preview feature let you view the print job before sending it to the printer. It uses GhostScript and GhostPCL to
render print jobs in PDF format. You must install GhostScript and GhostPCL to use this feature. These tools can be
downloaded for free and installed selectively during Xlpd install. Also, you can install them manually after the
installation. If you have already installed these programs for a different product, you can use the existing
executables.

Note

To preview a print job, first, you have to install GhostScript and GhostPCL. Go to the following links to
download the setup files.

GhostScript: http://www.ghostscript.com/download/gsdnld.html

GhostPCL http://www.ghostscript.com/download/gpcldnld.html
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To Preview a Print Job

bR

Click [Options] in the [Tool] menu. Options dialog box is displayed.

Click the [Preview] tab.

For GhostScript path, enter the path for GhostScript executable file. Filename is gswin32.exe.

For GhostPCL path, enter the path for GhostPCL executable file. Filename is pcl<Versionnumber>-win32.exe.
Click OK to save the changes.

In Xlpd, right click on a print job you want to preview and select "Preview this print job".

6.6 Email Notification

Xlpd can send email notification when an error occurs or Xlpd stops or restarts. To receive email notifications,
follow the steps below:

Nouohr~whE

Click [Options] in the [Tool] menu. Options dialog box is displayed.

Click the [Advanced] tab.

Select the [Enable email notification] option.

In the [From] field, enter the email address that will be used as the sender's email.

In the [To] field, enter the email address you will be receiving notifications.

In the [SMTP server] field, enter the IP address or the domain name of the SMTP email server.

In the [Port] field, enter the port number for the SMTP server. Default port number for SMTP server is 25.

To Authenticate User Before Sending Emails
If the SMTP server requires user authentication, you can use the user authentication feature. To enable this, follow
the steps below:

1.

ahrwnN

Click [Options] in the [Tool] menu. Options dialog box is displayed.
Click the [Advanced] tab.

Select the [Authenticate user before sending emails] option.

In the [User name] field, enter the user name for the email server.
In the [Password] field, enter the password for the user account.
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7 Print

This section provides descriptions on text or PS (PostScript) file printing process and methods to directly print files
in application programs.

7.1 Change Printer
When Xlpd is run for the first time, a printer in the default queue is designated as the default Windows printer.

Select the queue to which the printer will be changed from the queues list.
Click [Properties] in the [Queue] menu. Queue Properties dialog box opens.
Click [Setup] in [Printer Setup]. Print Setup dialog box opens.

Select printer.

Click [OK].

akrwpnE

7.2 Print PS and PCL Files

PS (PostScript) and PCL (Printer Command Language) files are processed by an application via a corresponding OS
printer driver. The files are sent to printers and interpreted for printing. For printing a PS/PCL file, the file should be
sent to the printer as is.

For printers that use printer languages other than PS and PCL, use a printer driver that supports the corresponding
languages in the application programs.

To Print PS and PCL Files:

1. Select a queue to print. If a queue does not exist, select the default queue.

Click [Properties] in the [Queue] menu.

Click the [Data Format] tab.

Clear [Apply text format when print].

Click [OK].

The remote host gives a command to print a PS file with an LPD printer as follows:
$ lpr -Pserver test.ps or $ lpr -dserver test.ps

or W

Note
Printing commands vary slightly according to host types. Descriptions of printer setup and printing
commands by host are given in 'Remote Printer Setup'.

7.3 Print by Formatting Text File

Xlpd permits text file printing by adjusting space or font sizes. It also enables direct printing of a text file without
formatting. In such case, a file is printed via the same process as 'Print PS and PCL Files'.

To Format and Print Text File:

Select a queue to print with. If a queue does not exist, select the default queue.

Select [Queue] -> [Properties]. Queue Properties dialog box opens.

Click the [Data Format] tab.

Turn on [Apply text format when print].

Click [Font]. Font dialog box opens

Click [OK] after selecting a font.

Set margins in [Margin] field.

To print a UNIX system text document in a Windows environment, select [Convert CR to CRLF (Carriage
Return & Line Feed)].

Click [OK].

Nk~ WN

©
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10. Remote hosts makes a command to print a text file with an LPD printer as follows:
$ lpr -Pserver test.txt or $ lpr -dserver test.txt

Note
When using a page printer, such as a laser printer, you may have to select the [Appemd FF(Form Feed) to end
of data] option to print the last page.

7.4 Print File Directly in Application Program

Afile can be printed with a printer connected directly with a PCin a UNIX application program via Xlpd.
Xlpd Settings:

1. Select a queue with a printing job.

2. Select [Queue] -> [Properties]. Queue Properties dialog box opens.
3. Click the [Data Format] tab.

4. Clear [Apply Text Format when print].

5. Click [OK].

Printing in Netscape:

1. Click [Print] in the menu.

2. Enter the following in the print screen [Print Command] : lpr -Pprinter_name printer_name in UNIX is that
used at printer registration.

3. Click [Print].

7.5 Manage Print Jobs

Printing tasks sent to Xlpd are displayed in the jobs list of the queue. The requested print job is either transferred
immediately to a printer or kept on the jobs list acording to the queue options.

Jobs displayed in the jobs list can be printed when necessary, or deleted. Select a job and right-click on it to display
menus related to the print job.

Job Search Conditions Settings
Only jobs satisfying the search conditions can be displayed.

1. Select [Find] in the [Tools] menu.

Designate a queue of jobs to find in [Queue].

Select the status of jobs to find in [Job status].

Select the owner of jobs to find in [Owner].

Enter a character string to search in [Keyword].

6. Click [Search] to display only those jobs in the jobs list satisfying the search conditions.

abrwn

Make Job Wait after Receipt

On receiving a printing request from an LPR client, Xlpd receives the print job, transfers it to the set printer and
starts printing. Via the settings, the requested print job can be kept on expect in the jobs list rather than being
transferred immediately to a printer.

1. Select the queue to which to set a print job on standby in the jobs list.
2. Select [Properties] in the [Queue] menu.

3. Click the [General] tab.

4. Turn off [Print received jobs immediately].

5. Click [OK].

Finished Job Processing
After the requested printing job is successfully transferred to a printer, it can be left in or deleted from the jobs list.
Afinished job can be left for printing later on, deleted when Xlpd ends, or deleted immediately upon completion.

Print- 29



Select [Properties] in the [Queue] menu.
Click the [General] tab.
Select [Delete finished jobs].

bR

6. Click [OK].
Print Saved Job

1. Select the queue with a stored print job or select all queues.

2. Move mouse to the job in jobs list.
3. Right-click and select [Print Selected Job].

Delete Saved Job

1. Select a queue with a stored job or select all queues.
2. Move mouse to the job in the jobs list.
3. Right-click and select [Delete Selected Job].

Delete Finished Job

1. Select a queue with a stored job.
2. Move mouse to jobs list.
3. Right-click and select [Delete All Finished Jobs].

Delete All

1. Move mouse to jobs list.
2. Right-click and select [Delete All Jobs].

Refresh

Spool file saved in the system is read and the jobs list is renewed.

1. Select specific queue or select all queues.
2. Click the [Refresh] button on top of jobs list.

Select the queue with which to change the finished print job processing options.

When [Delete finished jobs] is turned on, select [When Xlpd exits] or [When successfully printed].

Manual - Xlpd
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8 Log Management
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All messages generated during Xlpd processing can be viewed via a separate log viewer. The list display conditions

in the log viewer can be changed by queue, log type, date, character string and etc.

To Open Log Viewer:
Log Viewer can be opened via the following method.

1. Click [Log Viewer] in the [Tools] menu.

To Change Maximum Log File Size:
The following settings are required to change the log file size limit.

1. Click [Options] in the [Tools] menu.
2. Click the [Log] tab.

3. Enter a number in [File Size Limit].
4. Click [OK].

If a log grows larger than the maximum designated file size, the previously saved log is saved under a different

name.
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