Xshell® Manual

This software and various documents have been produced by NetSarang Computer, Inc. and are protected by the Copyright Act. Consent from the copyright holder must be obtained when duplicating, distributing or citing all or part of this software and related data.

This software and manual are subject to change without prior notice for product functions improvement.

Xlp™ and Xft™ are trademarks of NetSarang Computer, Inc. Xmanager® and Xshell® are registered trademarks of NetSarang Computer, Inc. Microsoft Windows® is a registered trademark of Microsoft®. UNIX® is a registered trademark of AT&T Bell Laboratories. SSH® is a registered trademark of SSH Communications Security. Secure Shell is a trademark of SSH Communications Security.

This software includes software products developed through the OpenSSL Project and used in OpenSSL Toolkit.

NetSarang Computer, Inc.

4701 Patrick Henry Dr. BLDG 22 Suite 137 Santa Clara, CA 95054

http://www.netsarang.com/
About Xshell

Xshell is a powerful SSH, TELNET and RLOGIN terminal emulator software operating on the Windows platform. Windows users can conveniently and securely access UNIX/Linux hosts using Xshell. SSH (secure shell) protocols support encryption and user authentication for secure connections on the Internet and can replace legacy protocols, such as TELNET and RLOGIN.

Key Functions

This section provides descriptions on key functions of Xshell.

General
- Supports SSH1, SSH2, SFTP, TELNET, RLOGIN and SERIAL protocols
- Supports Windows Vista/7/8/10, Server 2008/2012/2016
- Supports OpenSSH and ssh.com servers
- Supports having multi tabs in a single window
- Supports displaying multiple tab groups in a single window
- Multi-user setting
- Keep alive option
- SOCKS4/5, HTTP proxy connection
- Custom key mapping
- VB, Perl, Jscript scripting
- IPv6 support
- Kerberos (MIT Keberos, Microsoft SSPI) authentication support
- SSH/Telnet 추적

Session Management
- The Session Manager provides a convenient way to manage and run multiple sessions
- Create and manage session files for both local and remote hosts
- Supports Sessions dialog box, address bar, local prompt, shortcut to session, and links bar to open sessions
- Provides a default session for quick connection
- Simultaneous connection with multiple sessions
- Address bar supports URL commands and allows connection to a remote host with or without a saved session
- Supports automatic login and login scripts
- Supports folder and tree view in the Sessions dialog box
- Batch update sessions
- Import and export sessions

Security
- RSA/DSSA/ECDSA/ED25519 Public key, Password and Keyboard interactive user
authentication
- RSA/DSA/ECDSA/ED25519 New Key Wizard and import/export key
- SSH PKCS#11 Support
- User authentication using Xagent (SSH user authentication agent)
- AES128/192/256, 3DES, BLOWFISH, CAST128, ARCFOUR and RIJNDAEL encryption algorithms
- SHA1, SHA1-96, MD5, MD5-96 and RIPEMD160 MAC algorithms
- zlib compression
- Host Keys dialog box
- User Keys dialog box
- Supports using master password to encrypt password

Terminal
- Unicode-based terminal buffer
- VT100, VT220, VT320, XTERM, LINUX, SCOANSI and ANSI terminals
- Fixed terminal size option for standardized output
- Horizontal scroll bar while in fixed terminal size
- Multi-language output encoding (UTF-8)
- Compose Bar for sending strings to multiple sessions
- Compose Pane for sending multiple lines of strings to multiple sessions
- Scroll buffer enabling up to 2,147,483,647 lines to be saved
- Character string search using regular expressions
- Column unit text selection
- Supports multi-byte character strings at copy & paste
- Designates delimiters of double-click word selection in the terminal window
- Triple click selects one line
- Bold font and ANSI color code
- Xterm terminal mouse
- Xterm 256-color mode
- Linux Meta key emulation
- Prints terminal screen
- Set line spacing and margins in the terminal window
- Search a user specified web browser for selected text
- Various bell options

Tunneling
- TCP/IP and X11 forwarding
- Dynamic port forwarding using SOCKS4/5
- Tunneling pane for observing and managing active forwarding channels
- Instance tunneling to add/remove or modify tunneling to the current connected session

Appearance
- Dockable UI for the main window
• Theme selection feature
• Convenient and powerful user interface
• Supports custom layout
• Color schemes edit/import/export feature
• Change cursor color and blinking
• Easily changeable fonts via the Font button
• Apply separate fonts for ASCII and non ASCII characters
• Designate frequently used character strings as quick commands: Quick Commands Bar, Quick Commands Pane
• Customizable Standard Buttons on toolbar
• Security–lock, session selection, and network up/down traffic information display in the status bar
• Full screen view (Alt+Enter)
• Transparency options

Local Command
• Local shell prompt for advanced users
• Local commands, including open, ssh, telnet, rlogin, sftp, and ftp
• Local Windows commands, such as ping, ipconfig, netstat, and nslookup
• Escape to the local prompt during connection

Interoperability
• Interoperable with Xmanager program for X11 forwarding
• Interoperable with Xagent program for agent authentication and forwarding
• Interoperable with Xftp program for file transfers
• Edits scroll buffer in notepad
• Sequentially selects Xshell window via the menu command

String Transfer and File Management
• Send and receives files via FTP/SFTP
• Send and receives files via X/Y/Z MODEM
• Send ASCII files
• Send Delay for preventing data loss
• Auto save and support for various logging formats during session logging
• Page setting and print preview

Minimum System Requirements
• Processor: Intel® compatible
• Operating System: Microsoft Windows® 7 or higher
• Storage Space: 50MB of available space
• Memory: 512 MB
• Network: TCP/IP network
Install and Uninstall

The Xshell installation program was created using InstallShield®. A variety of installation options can be changed during installation. However, it is often sufficient to simply click [Next].

To uninstall Xshell, use the standard Windows add/remove functions. Run [Add/Remove Program] in the control panel and select to uninstall Xshell from the list. Even when the program is uninstalled, the registry information, log files and data files created by the user are not removed. The information and files are available for reuse when the program is reinstalled. If you want to remove all the files and registry information completely, remove the following explicitly:

**Registry Information:**
- \HKEY_CURRENT_USER\Software\NetSarang\Xshell

**File and Folder:**
- “User’s Documents Folder”\Netsarang Computer\6\Xshell
Start

This section provides descriptions of the methods to create a TELNET/RLOGIN or SSH session and to connect to UNIX/Linux hosts. TELNET sessions are very simple. However, an SSH session occasionally requires a user key registration in the server prior to connection. If you need user key registration for SSH sessions, see ‘Public Key User Authentication’.

Create Session


![New Session Properties dialog box](image)

Fig. 1: New Session Properties dialog box
2. Enter a session name in [Name].
4. Enter server host name or IP address in [Host].
5. Enter port number used by the remote server in [Port Number].
6. Click [OK].

**Connect to Remote Host**

The following is the process for connecting to a remote host via an SSH session. If a session is not available, see 'Create Session'.

1. Select [Open] from the [File] menu. **Sessions** dialog box is displayed.
2. Select session for connection from the sessions list and click [Connect]. **SSH User Name** dialog box is displayed.

![SSH User Name dialog box](image)

Fig. 2: SSH User Name dialog box

3. Enter user name and click [OK]. **SSH User Authentication** dialog box is displayed.
4. To attempt **Password** authentication, enter password in [Password] and click [OK].

5. To attempt **Public Key** authentication, first select a user key from the list. Enter [Passphrase] of the selected user key and click [OK].

   ![SSH User Authentication dialog box](image)

   **Fig. 3:** SSH User Authentication dialog box

   **Note**

   If a user key is not available, see 'Public Key User Authentication'.

6. To attempt **Keyboard Interactive** authentication, click [OK] and answer the questions given during connection process.

**Exit Xshell**

To disconnect with a session, enter ‘exit’ in the terminal screen prompt or select [Disconnect] from the [File] menu.

   ![Exit Xshell](image)

   **Note**

   If a session is disconnected with the [Revert to local shell when connection is closed] option selected, the session tab remains open and reverts back to local shell. Under local shell status, the current session file’s path prompt is displayed in the terminal screen and local commands, such as open, telnet, ssh, and ping can be executed.
To end **Xshell**, select [Exit] from the [File] menu.
Session Management

Session is a file containing information about remote host connection setup. By creating a session, users can set different options for different remote hosts. The Sessions dialog box shows all sessions created and enables to create and edit sessions.

Users can connect to a remote computer without creating a session. For this purpose, Xshell provides a default session which is ready to use after installation.

Session Management

To Create a New Session:
2. Enter connection information.
3. Click [OK].

To Open the Sessions Dialog Box:
- Click the standard [Open] button.

To Edit a Session:
1. Open the Sessions dialog box.
2. Select a session to edit.
3. Click the standard [Properties] button.
4. Click [OK] after completing session editing.

Note
You can edit multiple sessions simultaneously simply by selecting all the sessions you want to edit and clicking [Properties].

To Rename a Session:
1. Open the Sessions dialog box.
2. Right-click on the session to rename.

Note
Session name must be a valid file name.

To Copy a Session Under Different Name:
1. Open the Sessions dialog box.
2. Select a session to copy under a different name.
3. Click the standard [Save As] button.
To Delete a Session:
1. Open the **Sessions** dialog box.
2. Select the session to delete.
3. Click the standard [Delete] button.

To Create a Shortcut to Session:
1. Open the **Sessions** dialog box.
2. Select a session for which to create shortcut.
3. Click the standard [Create Shortcut] button.
4. Select a folder to save shortcut.
5. Click [OK].

To Change Default Session Properties:
To open the default **Session Properties** dialog box, select one of the following:
- Select [Properties] from the [File] menu in local shell.
- Click the arrow next to the standard [Properties] button in the main toolbar and select [Default Session] from the list.

**Note**
Default session is used when connecting with SSH, TELNET, RLOGIN and SFTP using a local prompt or the Address Bar.

To use a connection command in the local prompt, see ‘**Xshell Local Command**’. For connections using the address bar, see ‘**Address Bar**’.

To Create a New Session Folder:
1. Open the **Sessions** dialog box.
2. Click an arrow next to the standard [New] button and select [Folder] from the list.
3. Enter folder name.

To Copy a Session file to Another Computer:
2. If you would like to use the session file’s password on another device, set the Master Password.
3. Copy a session file (*.xsh) or email it to another computer.
4. On the device to use the session file, set the exact same Master Password.
5. Select [Import] from the File Menu.

**Session Properties**
Open the **Session Properties** dialog box to create a new session or to edit a session.

To Open the Session Properties Dialog Box:
- Select [New] from the [File] menu.
- Select [Properties] from the [File] menu.
- Click the standard [Properties] button.
**Connection**

In the connection settings, information about session connections may be set. In most cases, users can connect to a remote host with the connection settings only.

**Name**

Enter an intrinsic name for the session. The name becomes the session file name, and must be comprised of a valid characters for a file name.

**Protocol**

Select a connection protocol to use when connecting to a remote computer. The protocols supported are SSH, SFTP, TELNET, RLOGIN, SERIAL, and LOCAL.

**Host**

Enter host name or IP address of the remote computer.

**Port Number**

Enter the port number of the protocol selected above. When a protocol is selected from the protocols list, the default protocol port number is automatically entered. If a remote computer is using another port number, the port number must be directly entered. Default port numbers for each protocol are 22 for SSH/SFTP, 23 for TELNET, and 513 for RLOGIN. SERIAL and LOCAL sessions do not require a port number.

**Description**

Add a short description about the session. This information will be displayed on the session tab after running the session.

**Reconnect**

This setting is used to restart the session if the connection is lost. Set the number of seconds desired between reconnection attempts. If a connection is not established during the user specified duration of minutes, the connection will cease. If the specified time is set to 0, a connection will be attempted.

**Use Nagle’s algorithm**

If this option is selected, transfer efficiency may be slightly higher at the expense of a slower key response rate.

**Connection > Authentication**

In the user authentication settings, the authentication method, user name, password, user key, etc. may be designated.

**Method**

Select an authentication method among Password, Public Key, Keyboard Interactive, GSSAPI and PKCS11. If the selected authentication method is not supported by the SSH server, a dialog box asking about the user authentication method is displayed during connection.

---

**Note**
If the PC running Xshell is utilizing an Xshell supported Kerberos module, Xshell can only automatically authenticate to the SSH server if GSSAPI authentication is selected.

**User Name**
Enter a user name for login. User name is the remote computer login account. If this field is left blank, a dialog box asking for the user name is displayed during connection.

**Password**
Enter a remote user account password. This value is valid when *Password* authentication is selected. If this field is left blank, a dialog box asking for the user authentication is displayed during connection. The password is encoded and saved in the user’s PC. For greater security, leave this field blank.

**User Key**
Select a user key to use when Public Key authentication is selected. If this field is left blank, a dialog box asking about the user authentication is displayed during connection. If a user key is not in the list, a key must be created and registered in the remote SSH server.

**Passphrase**
Enter the passphrase for the selected user key. The entered key passphrase is encoded and saved in the user’s PC. For greater security, leave this field blank.

**Connection > Authentication > Login Prompts**
It is necessary for *Xshell* to recognize the server user name/password prompt in order to automate the login process for the TELNET or RLOGIN protocol. In general, the default value is used.

**TELNET**
Enter the user name and password prompt to automate TELNET login process. Note that blanks are recognized as valid characters.

**RLOGIN**
Enter the password prompt for RLOGIN protocol. A password may not be needed depending on the RLOGIN server settings. Note that blanks are recognized as valid characters.

**Connection > Login Scripts**
For the login script settings, commands to be automatically entered in the terminal may be defined. After a successful login to a remote server, commands are sequentially executed in the order displayed in the list. This feature is very useful when you login to another server after the first login to a remote server.

**Execute the Following Expect and Send Rule**
Select this option to use expect and send rule.

**Add**
Open the *Expect and Send Rule* dialog box. When rules editing is complete, the rule is added to
the list.

**Edit**
Open the **Expect and Send Rule** dialog box and edit the selected rule.

**Execute script when session starts.**
Set a script file to execute after a session connection.

**Connection > SSH**
Set general SSH protocol options.

**Protocol Versions**
Select an SSH protocol version to use. SSH2 is safer than SSH1 and offers more capabilities.

**Use Xagent (SSH Agent) for Handling Passphrase**
Select this option when using Xagent. Using Xagent, entering a passphrase is not required during the public key user authentication process.

**Launch Xagent Automatically**
Xagent is automatically executed when necessary. When this option is selected, users do not need to execute Xagent in advance.

**Use ZLIB Compression**
A compression algorithm is used to compress all SSH connection data. In an environment where network speed is slow, use this option to improve the speed.

**Do Not Allocate a Terminal**
Select this option when not using terminal. If this option is turned on, a terminal(tty) for input/output is not assigned and thus input/output on the screen is not possible. Use this option if you want to use tunneling only without terminal access.

**Connection > SSH > Security**

**Encryption**
Encryption algorithms are used to encrypt and decrypt network traffics. Users may select a preferred encryption algorithm from the list. If <Cipher List> is selected from the list, multiple algorithms may be attempted in the order appearing in the list. To edit the list of <Cipher List>, click [Edit].

**MAC (Message Authentication Code)**
MAC is added in SSH2 for greater security and to ensure data integrity. If <MAC List> is selected from the list, multiple algorithms are tried in the order appearing in the list. To edit the list of <MAC List>, click [Edit].

**Key exchange**
Users can select the initial Key Exchange for the SSH connection. The desired algorithm can be
selected from the list. If the server does not support the selected algorithm, the connection will fail.

**Connection > SSH > Tunneling**

In the tunneling setting, TCP/IP, Dynamic and X11 forwarding rules may be set. These settings are valid only when the SSH protocol is selected in Connection setting.

For details on tunneling setting, see ‘Tunneling Service’.

**Connection > SSH > SFTP**

Set SFTP protocol related options.

**Startup Folder**

Set a local and remote folder with which to start after a successful login via SFTP protocol.

**Connection > TELNET**

Set TELNET protocol related options.

**Use XDISPLOC Telnet Option**

Uses XDISPLOC Telnet option to pass display (PC X server) information to server. If you are using a PC X server such as **Xmanager**, use this option to execute remote X11 applications from a local PC.

**Display**

Enter the DISPLAY value to pass upon login. $PCADDR value is translated automatically to IP address of a local PC right before it is passed to server. The DISPLAY number must match the DISPLAY number of the X server currently running on the PC.

**Option Negotiation**

This option determines who initiates the attempt to negotiate additional TELNET options. When set to Active, after a connection has started, Xshell initiates the negotiation. Passive waits for the server to initiate the negotiation. The values may have to be different depending on the server or firewall settings. If both the server and Xshell are set to Passive, the negotiation will not proceed. Conversely, if Active is selected and the firewall is enabled on the server, the negotiation may fail.

**Connection > RLOGIN**

Set RLOGIN protocol related options.

**Terminal Speed**

Designate terminal speed to be passed to rlogin server.

**Connection > SERIAL**

In serial setting, serial connection options may be set. Instead of using the traditional terminal environment, RS232C SERIAL connection lets you use your PC to connect to UNIX machines that has no graphic card support or where direct access to console is not available. To use Serial
connection through **Xshell**, serial interface must be installed in the host system.
For details on serial setting, see *Serial Connection*.

**Connection > PROXY**

**Proxy Server**
Select a proxy server to use in this session.
For details on proxy setting, see *Proxy Setting*.

**Connection > Keep Alive**

Send keep alive messages while this session is connected
Send keep alive messages every user defined interval (seconds) to a remote computer. This is useful when a connection is unexpectedly closed while the connection is idle. In some network environments, the gateway or firewall system forces a disconnection if data transfer is not made for a defined period of time.

Send string when network is idle
Certain systems, if there is not user key input, the sessions is automatically determined to be idle and the session is ended. Typically, the NF value, /n, is used.

Send TCP keep alive packets when network is idle
Users cannot designate the interval or cycles in which keep alive packets are sent at the OS level.

**Terminal**

In the terminal setting, terminal types and other related options may be set.

**Terminal Type**
Select a terminal type to use. **Xshell** supports VT100, VT102, VT220, VT320, ANSI, SCOANSI, LINUX and XTERM terminals. The terminal type may change after a connection is made depending on the remote user’s settings. Users can check the current terminal type using the echo $TERM command.

**Terminal Size : Columns**
Enter the number of columns in the terminal. The value is applied when the column size is fixed or if the terminal is reset after the connection is made.

**Terminal Size : Rows**
Enter the number of lines in the terminal. The value is applied once the terminal is reset after the connection is made.

**Fixed column size**
With this option selected and a connection established, even if the user changes the window size, the column size, specified by the user, will not change. If the window size is smaller than the
column size, a horizontal scroll bar will be shown.

**Reset terminal size when connected**
When a session is run, Xshell’s window will be resized to the user defined terminal size.

**Scroll Buffer**
Designate the row unit scroll buffer size.

**Push Erased Screen into Scroll Buffer**
With this option enabled, clearing the screen or resetting the terminal will push the contents into the Scroll Buffer. The erased contents can be viewed again using the mouse scroll.

**Encoding**
Select terminal output encoding. This value must be a language the remote server uses. If Default Language is selected, Xshell uses the Windows encoding.

**Treat Ambiguously sized characters as wide**
Characters without size information will be treated as 2-byte characters.

**Terminal > Keyboard**
In the keyboard settings, users may set the character strings sent by their PC’s keyboard to the server.

**Function Key Emulation**
Set function keys appropriate for your terminal type. If Default is selected, the function key is automatically assigned according to the terminal type designated in the Terminal setting.

**Specify an Alternate Key Mapping File**
Using a custom key mapping file, users can manually assign a string to each function key (F1~F20) and it will be sent to the server when pressed.

**Delete Key Sequence, Backspace Key Sequence**
Select a character string to be sent when the user presses the Delete or Backspace key.

**Meta Key Emulation**
Treat the Alt key as the Meta key for application programs which use meta keys, such as Emacs.

**Use Left ALT Key as Meta key**
Treat the Left Alt key as the Meta key.

**Ctrl+Alt works as Alt Gr**
If Ctrl + Alt are pressed simultaneously, it will be recognized as the Alt Gr key.

**Use Right ALT key as Meta key**
Treat the Right Alt key as the Meta key.
Terminal > VT Mode
Set the initial values for each terminal mode.

Auto Wrap Mode (DECAWM)
Activate auto wrap mode at startup.

Origin Mode (DECOM)
Activate origin mode. When this option is activated, the cursor moves based on the location designated by the server.

Reverse Video Mode (DECSCNM)
Enables Reverse Video Mode when the session starts. When this option is activated, the screen foreground and background colors are reversed.

New Line Mode (NLM)
Enables New Line Mode when the session starts. When this option is activated, both CR and LF are sent when Enter key is pressed. If this option is not selected, Enter key sends CR only.

Insert Mode (IRM)
Enables Insert Mode. When this option is selected, characters received from the remote server are inserted into where the cursor is located and the existing characters are not erased.

Echo Mode (SRM)
When this option is activated, a character string to send to server is displayed on screen and then transferred to server.

Initial Cursor Key Mode (DECCKM)
Set initial cursor key mode value.

Initial Numeric Keypad Mode (DECNKM)
Set default setting for Keypad mode.

Terminal > Advanced
Set advanced terminal options.

Restrict Mouse Use at Terminal with Shift Key
Some applications such as ‘vi’ and ‘mc’ can use mouse click and drag to make a selection or change the directory. When this option is selected, press the Shift key while using the mouse and Xshell uses the mouse input to perform actions such as making selection on the screen.

Erase Screen Using Background Color
Use the current terminal background color rather than the background color set in the color scheme when erasing screen.

Receive LF as CR+LF
Display both CR and LF in the terminal screen when LF is received from the server.
**Scroll to the Bottom when Pressing the Key**
Scroll to the bottom of the terminal screen when a user enters a key.

**Scroll to the Bottom at Terminal Input/Output**
Scroll to the bottom of the screen when text is displayed on the terminal screen.

**Enable Destructive Backspace**
Erase a letter to the left of the cursor, when the Backspace key is pressed, and move the cursor to the erased character's position.

**Disable Blinking Text**
Blinking texts do not blink and are displayed with solid color.

**Disable Terminal Title Change**
Do not change the Xshell title bar. In most cases, the title bar displays the folder and host name according to a request from a remote computer.

**Disable Terminal Printing Feature**
Display the terminal on screen without printing it when a request for terminal printing is received from server.

**Disable Switching to Alternate Terminal Screen**
Do not use an alternate screen for certain application programs, such as vi. When an alternate screen is used, and the application is terminated, the terminal area goes back to the screen before the application is started.

**Disable Terminal Size Change upon Request**
Ignore a terminal size change signal from the server.

**Answerback to ^E**
For output ^E (ENQ, Enquiry), most terminal emulators will answerback with its name. Xshell defaults to the same behavior, but the user may define which characters to answerback with.

**Use the built-in font to draw line characters**
When outputting lines or boxes with line characters (─, |, ├, ┼, etc.) use Xshell’s default font instead of the user defined font.

**Use the built-in font to support Powerline**
Enable this option for a cleaner output when using Powerline.

**Appearance**
In the appearance setting, the terminal window’s colors and fonts may be set.

**Color Scheme**
Select a color scheme. Xshell provides several default color schemes. Add a new color scheme or edit an existing color scheme in the Select Color Scheme dialog box.
Font
Select a font to be used for Roman characters and ASCII numbers. Only fixed width fonts are listed. A font may also be selected by pressing the standard [Fonts] button.

Asian Font
Select the font to be used for non ASCII characters such as Chinese. If you change the font via the Standard Button toolbar, this value will be replaced by the font selected for ASCII characters.

Font Size
Select the desired font size. If the desired font size is not displayed, it can be manually entered.

Font Quality
Select the quality of the characters displayed in the terminal.

Bold
Select a method to express bold characters.

Cursor Color
Select the cursor’s color.

Text Color
Select the color for text within the cursor.

Use blinking cursor
Enable this option to have the cursor blink.

Speed
Select the speed at which to blink the cursor.

Appearance
Select the type of cursor.

Appearance > Window
In the window settings, set the margins, spacing, tab color, and background of Xshell’s terminal window.

Margin
Set terminal window margins.

Spacing
Set spacing between lines and characters outputted in the terminal window.

Tab Color
Select or choose the color of the session tab.

Background Image
Select a BMP image file to set as the terminal’s background image.

**Position**
Select where you would like to position the background image.

**Appearance > Highlight**
Highlighting will highlight user defined keywords with color or font conversions. Set the Highlight Set to be used to manage keywords to emphasize. For more information on settings keywords and managing highlight sets, see “Highlight Set Settings.”

**Advanced**
In the advanced settings, set quick command sets, tracing, bell options, and log options.

**Quick Command Set**
Select the default quick command set to be used in a session. The selected quick command set is displayed in the quick command bar when the session is started. For more information on quick commands and settings, see “Quick Command Bar Settings.”

**Disable Shortcut Key to Quick Command**
Ctrl+F1 and Ctrl+F2 keys are not used as shortcut keys to quick commands. The corresponding key values are sent to the server.

**Xftp Option**
Xftp can be called from Xshell using the current connection’s information. When the Telnet and Rlogin protocols are being used, Xftp will utilize the FTP protocol. A port number other than 21 can be set here.

**Send Delay**
Pasting a large number of strings into a terminal may cause some of the data to be lost depending on the network or server environment. In this case, it is recommended to use Send Delay to manually delay the transmission.

**Send Delay : Character Delay**
Set the string paste delay between the characters in milliseconds.

**Send Delay : Line Delay**
Set the string paste delay between lines in milliseconds.

**Send Delay : Prompt**
When pasting multiple lines in sequence, paste the following line only when this user defined string appears. Set a “Max Wait” time to withhold pasting the following line if the specified string does not appear.

**Advanced > Trace**
In the tracing settings, set protocol tracing options. This feature is helpful when you want to trace
detailed protocol messages to solve a specific problem. A tracing message is displayed in the terminal screen.

**SSH Version, Algorithm Exchange and User Authentication**
Display information about version exchange, encoding algorithm, compression method, and server and user authentication.

**SSH TCP/IP and X11 Tunneling**
Display port forwarding information on screen.

**SSH Packet**
Display SSH Packet message ID information.

**TELNET Option Negotiation**
Display the TELNET option exchange process between **Xshell** and the telnet server on the screen.

**Advanced > Bell**
Xshell incorporates several options to utilize the typical system's bell sounds using the ASCII character number 7(Bell character, ^G).

**Bell Settings**
Select how to acknowledge the bell character.
- **None (Ignore bell request)**: Do not respond to the server's bell character output
- **Default system alert sound**: Play Window’s default alert sound
- **PC Speaker**: Play the bell sound via the PC's speakers
- **Play the following sound**: Play a user defined .wav format file

**Flash window and taskbar if window is not focused**
If the bell enabled window is behind another window or if the user is working on another program, the icon on the Windows taskbar and the window itself will flash to notify the user that there was a bell output on the remote system.

**Ignore Settings**
Non system alerts and etc. may cause unintended bell rings due to incorrect output strings in the terminal. Time intervals can be set to avoid unintended bell rings.

**Temporarily disable the bell if the bell request is received more than once during the following time duration.**
Any bell requests made more than once during the time duration set here (seconds) will be ignored.

**Re-enable it after the following period of time.**
After a bell request has been ignored, bell requests will once again be accepted after no bell requests are made in the time duration set here (seconds).
Advanced > Logging

In the logging settings, set the options related to log creation.

File Path
Specifies the path of the log file. The string conversion formats available at file creation are %n: session name, %Y: current 4 digit year, %m: current 2 digit month, %d: current 2 digit day, %t: current time (%H-%M-%s), %h: current 2 digit hour, %M: current 2 digit minutes, %s: current 2 digit seconds.

Overwrite if the file exists
If a file with the same name exists in the destination folder, specify whether or not to overwrite the file. If this option is not selected, a sequence number is appended to the file name.

Start Logging upon connection
Logging is automatically started when a session is connected to a remote host.

Prompt me to choose a file path when logging starts
A prompt will be displayed when logging starts which allows the user to specify where to save the log file rather than the default path.

Include terminal code
Choose one of the following logging methods.

- Record only printable text
- Record terminal code as well as printable text

If you include terminal code, all contents (color, string output status, etc.) will be recorded.

Timestamp: Log file records
Log file records will show the time the log was output.

Timestamp: Format
This is how the the date and time are formatted: %n: session name, %Y: current 4 digit year, %m: current 2 digit month, %d: current 2 digit day, %t: current time(%H-%M-%s), %h: current 2 digit hour, %M: current 2 digit minutes, %s: current 2 digit seconds, %a: other OS expression for date and time, %l: line number.

Timestamp: Preview
Displays the formatted timestamp based on current date and time.

File Transfer
This sections deals with X/Y/Z modem protocol file transfers during a terminal connection.

Folder
When transferring a file from remote servers, users can specify whether to save to a predetermined path or to have a prompt displayed so the user can specify each transfer.
Duplicate file handling
When a file with the same name exists, users can specify whether to automatically rename the file or to overwrite it.

Upload protocol
User can upload local files by simply dragging and dropping the file into Xshell. Specify which protocol to use during these uploads.

File Transfer : X/YMODEM
Set various options for file transfers using X/Y modem.

Option
Select the packet size to be sent to the remote server. If 1024 bytes is selected, the transfer speed will be faster, but it must be supported by the server.

Upload Command
When using the XMODEM or YMODEM commands in the File Menu or when dragging and dropping, the selected file is automatically transferred. Set the commands the server will use to prepare to receive the files at this time. For X/Y modem related commands, please refer to the related server manual.

File Transfer : ZMODEM
In the ZMODEM settings, set various options relating to ZMODEM file transfers.

Activate ZMODEM Automatically
Automatically start file send when remote ZMODEM program starts send. If this option is not set, the file must be received by selecting [Send with ZMODEM] in the [File] > [Transfer] menu. X/YMODEM cannot automatically be received and so [Receive with X/YMODEM] must be selected” from the [File] > [Transfer] menu.

Export
Sessions exported by Xshell are collected into a single convenient file. When this file is imported from another computer where Xshell is installed, the imported sessions may be used without additional setup. However, the password of the exported session file will not be available unless a Master Password has been set on the PC from which the session file was exported and the same exact Master Password has been set on the PC into which the session file is imported.

To Export Session:
2. Select the position where the exported file is to be saved and click [Next]. Session export results will be displayed.

Note
If ‘Clear Password’ is selected, the exported session file will not include the session password during the export. Also, even if ‘Clear Password’ is not selected, the password will only be
available if imported into the same computer under the same user. To use the session with the session password on another device you must first set a Master Password on the computer from which the session file is being exported and the same exact Master Password must be set on the computer into which the session file is to be imported.

3. Click [Finish] to complete sessions export.

Import

Xshell can import sessions exported by other computers.

To Import Session:
1. Select [Import] from the [File] menu. The Import/Export Sessions wizard is displayed.
2. Directly enter the file path exported from other computer or click the [...] button to select the exported file and click [Next]. Sessions are imported and the result is displayed.
3. Select how to handle sessions with the same file names.
4. Click [Next] to select the types of sessions to import.
5. Click [Finish] to complete session import.
Connection

Xshell provides various connection methods, such as the Sessions dialog box, local prompt, address bar, links bar, and shortcuts to session.

Connections without Session Files

Connection from the Local Prompt:
1. Enter one of the following commands in the local prompt:
   
   - [C:~]$ telnet hostname
   - [C:~]$ ssh hostname
   - [C:~]$ rlogin hostname
   
   ■ Note
   A port number must be designated if a remote host does not use the default port number. For information on commands, see ‘Xshell Local Command’.

Connection from the Address Bar:
1. Enter one of the following commands in the address bar:
   
   - telnet://hostname
   - ssh://hostname
   - rlogin://hostname
   
   2. Press Enter or click [Connect].

   ■ Note
   A user name and port number may be entered in the address bar. For details, see ‘Address Bar’.

Connections with Session Files

Connection from the Sessions Dialog Box:
1. Open the Sessions dialog box.
2. Select a session for connection.
3. Click [Connect].

■ Note
   If a remote host connection already exists, a new tab is opened or a new Xshell is started.

Connection from the Local Prompt:
1. Enter the following command in Xshell local prompt.
   [C:\~]$ open session file name

**Connection from a Shortcut:**
1. Double-click the shortcut icon of a session.

   ![Note](image)
   To obtain information about shortcut to session, see 'Session Management'.

**Connection from the Session Manager:**
1. Make sure the "Session Manager" is enabled in the [View] menu.
2. Select the session you want to connect to and double-click or press the Enter key.

**Sessions to Run Xshell Startup**
1. Select 'Options' from the [Tools] menu.
2. In the 'General' tab, click 'Add' and select session files to automatically connect upon Xshell startup.

**SERIAL Connection**
RS232C SERIAL connections lets you use your PC as a terminal when there is no video card in the UNIX system or if the console is not directly accessible. To use SERIAL connections via Xshell, the SERIAL interface must be installed in the host system.

**To Make Serial Connections:**
2. Enter a session name in [Session].
4. Select [SERIAL] from [Category].
5. Select the RS232C serial port number connected with the PC where Xshell is installed from [Port]. If the port number is not in the list or if the name is the same as the named pipe, enter it manually.
6. Select communication speed in [Baud Rate]. The value must match the server value. In general, 9600 is used.
7. Select the transferred data unit bit count in [Data Bits]. It must match the server value.
8. Select number of bits to indicate the end of data unit in [Stop Bits]. Make a selection according to server settings.
9. [Parity] is to verify errors in transferred data. Select one from none, odd, even, mark and space according to server settings.
10. [Flow Control] is for controlling data communications. Supported flow control methods are XON/XOFF and RTS/CTS. If a flow control is not set(None), data may be lost if data is sent faster than the serial line.
11. Create a new session by clicking [OK].
12. Make a connection as described in 'Connection with Sessions Files’ with the created session.
Connection with Kerberos

Xshell 6 supports MIT GSSAPI Kerberos and Microsoft’s SSPI Kerberos authentication. This article assumes that you have a working Kerberos server and client.

To create a new Kerberos session,
2. Enter a session name in [Name].
4. Select [Authentication] from under [Category].
5. Select GSSAPI from the [Method] list.

Note
If the PC running Xshell is utilizing an Xshell supported Kerberos module, Xshell can only automatically authenticate to the SSH server if GSSAPI authentication is selected.

6. To change the GSSAPI settings, click the [Setup] button.

Note
To connect to another server using Kerberos authentication from a server using Kerberos authentication, select the 'Allow GSSAPI credential delegation' option.

7. Click [OK] to save the GSSAPI settings.
8. Enter the user name.
9. Click [OK] to save the session file.
10. Click [Connect] to connect immediately or select the session file from the Sessions Dialog Box to connect.

You have finished creating a session that will use the Kerberos module. When this session opens, it will try to use the Kerberos credential for the specified user. It has to be the same user you defined in the Network Identity Manager.

Connection with PKCS #11

PKCS #11 is one of the public key cryptography standards. Xshell 6 can connect to a remote SSH server using a PKCS #11 encrypted hardware security token (HSM) or a smart card's RSA key.

To create a new PKCS #11 session:
2. Enter a session name in [Name].
4. Select [Authentication] from under [Category].
5. Select PKCS11 from the [Method] list.
6. Click the [Setup] button.
7. Enter the path of the middleware program that can connect to the hardware token that contains the user key. Or click [...] to browse for it.
8. If the pin number is set in the hardware token, enter the pin number.
9. Enter the user name.
10. Click [OK] to save the session file.
11. Click [Connect] to connect immediately or select the session file from the Sessions Dialog Box to connect.

Proxy Setting
Proxy server mediates between a network to which a user belongs and an external network to be connected with.
Add, edit and delete a proxy server in Proxy List dialog box.

To Add Proxy Server:
1. In [Connection > Proxy] category of Session Properties dialog box, click [Browse] in [Proxy Server].
2. Click [Add] in Proxy List dialog box. Proxy Settings dialog box is displayed.
3. Enter proxy server name, proxy server type, host information and user information.
Security

Xshell provides public key user authentication. Host keys and user key databases created in Xshell may be used in Xmanager and Xftp programs. Once a public key is created, it may be used in other programs without any additional configuration.

Public Key User Authentication

For public key user authentication, a pair of user keys must be created comprised of a public key and a private key. While public key authentication is carried out, the private key is used by Xshell to create a user signature and the public key is used by the SSH server to check the signature. A user key may be created from the SSH server or Xshell. If the user key is created from the server, the private key must be registered in the Xshell private key repository using Xshell import. If the user key is created from Xshell, the public key must be registered in the server.

To Create a User Key:
2. Create a user key according to instructions given by the New User Key Wizard.

Note
Register a public key on a server at the last stage of key creation. Registration methods vary depending on server types.

- **SSH1**: Copy the public key text and save it to $HOME/.SSH/authorized_keys file. Execute the following command to turn off the write permission of the files and directories.
  
  $ cd
  $ chmod go-w . .SSH .SSH/authorized_keys

- **SSH2-OpenSSH**: OpenSSH servers use this format. Copy the public key text and save it to $HOME/.SSH/authorized_keys2 file. Execute the following command to turn off the write permission of the files and directories.
  
  $ cd
  $ chmod go-w . .SSH .SSH/authorized_keys2

- **SSH2-IETF SECSH**: Certain commercial SSH servers, such as ssh.com server, use this format. Save a public key under an intrinsic name, such as mypublickey.pub and copy it to $HOME/.ssh2 directory. Add the following line to $HOME/.ssh2/authorization file:
  
  Key mypublickey.pub
  Execute the following command to turn off the write permission of the files and directories.
  
  $ cd
  $ chmod go-w . .ssh2
  $ chmod go-w .ssh2/authorization .ssh2/mypublickey.pub

To Register a Public Key in a Server:
1. Open the User Keys dialog box by selecting [User Key Manager] from the [Tools] menu.
2. Select a user key to register.
3. Click [Properties]. The User Key Properties dialog box is displayed.
4. Click the [Public Key] tab.
5. Select an appropriate type from the [Public Key Format] list.
6. Click [Save as a file] to save or copy the key content and register the key to the server according to the public key registration method above.

To Change the User Key Passphrase:
1. Open the User Keys dialog box.
2. Select a user key for which to change the passphrase.
3. Click [Properties]. The User Key Properties dialog box is displayed.
4. Click the [General] tab.
5. Click [Change Passphrase].

Note
Import, export, rename, delete, and create a user key in the 'User Keys Dialog Box'.

User Keys Dialog Box

The User Keys dialog box enables the creation and management of user keys. Open this dialog box by selecting [User Key Manager] from the [Tools] menu.

Import
Select a user key file and import it by opening the Open dialog box. Currently, Xshell can read the SSH1 protocol RSA key, the OpenSSH SSH2 protocol RSA/DSA key, the SSH.com key and the NetSarang Computer user key formats(*.pri).

Export
Save a selected user key file by opening the Save dialog box. Exported file types are NetSarang user keys or the OpenSSH SSH2 format. NetSarang Computer user key format files(*.pri) can be used in programs developed by NetSarang Computer, Inc.

Delete
Delete a selected user key from database.

Rename
Rename a selected user key. Key name must be valid as a file name.

Properties
Show user key attributes. Type, length, fingerprint, and public key may be viewed, and the key passphrase may be changed.

Generate
Open the New User Key Wizard.
Host Key Management

A host key is a remote host public key, and users can verify the host via its fingerprint. When a connection is made, the remote host sends its public key to Xshell. When the host key is valid and you trust it, you can save the host key to the database in Xshell. If a host key is not saved in the database, the SSH Security Warning dialog box will appear when you try to connect to the host.

SSH Security Warning Dialog Box

The SSH Security Warning dialog box is displayed when a remote host key is not saved in the host key database or the fingerprints of the remote host key and the saved host key are different.

Accept Once
Accept host key for this connection only. The host key is not saved and the same dialog box opens at the next connection. This is useful when a server host key changes often or the user rarely connects to the server.

Accept and Save
Save host key and process the connection. This dialog box does not open on the next connection. This is useful when the fingerprint is correct and the user connects to the host frequently.

Cancel
Host key is not accepted and connection is cancelled.

Host Keys Dialog Box

The Host Keys dialog box permits users to manage host keys of remote hosts to which connection is allowed.

Import
Import a host key by opening the Open dialog box. The imported host key is saved in the host key database. Files saved in the SECSH public key format can be imported.

Export
Export a selected host key by opening the Save dialog box. The exported keys are saved in the SECSH public key format and can be used in other programs.

Remove
Remove a selected host key from the database.

View
Open a selected host key with notepad.

Master Password

Master password can be used to save passwords more securely using the user defined master password. Xshell saves all password information in an encrypted format. However, since
passwords are encrypted using a fixed key, it has a risk of being exploited by hackers. When the master password is enabled and set, it is mixed in during password encryption adding an additional layer of security.

Master password uses a user defined keyword to encrypt the password section of the session data. When the master password is enabled, Xshell asks for the master password every time a new Xshell instance is started and a session is open. If the correct master password in not inputted, the session’s password is not able to be utilized and must be entered again manually preventing unauthorized access.

Note
Be sure to remember your master password. If you lose your master password, there is no way to retrieve the password information stored in the session files.
Maser Password settings are applied simultaneously to Xmanager, Xshell, and Xftp sessions.

To Enable Master Password:
1. Click on the Tools menu and then select Options.
2. Select the Security tab.
3. Click Set Master Password to open the Master Password dialog box.
4. In the Master Password dialog box, enter a new master password in the New Password field.
5. In the Confirm Password field, enter the new password again.
6. Click OK to save the changes.

Once master password is enabled, all sessions saved in the default location are re-encrypted using the new master password.

To Change Master Password:
1. Click on the Tools menu and then select Options.
2. Select the Security tab.
3. Click Set Master Password to open the Master Password dialog box.
4. In the Change area click Change to open the Master Password Change dialog box.
5. Enter the current master password in the Current Password field.
6. Enter the new master password in the New Password field.
7. Enter the new password one more time in the Confirm Password field.
8. Click OK to save the changes.

To Disable Master Password:
1. Click on the Tools menu and then select Options.
2. Select the Security tab.
3. Click Set Master Password to open the Master Password dialog box.
4. Click the Remove button to open the Remove Master Password dialog box.
5. In the Remove Master Password dialog box, enter the master password and click OK.

To Reset the Master Password:
1. Click on the **Tools** menu and then select **Options**.
2. Select the **Security** tab.
3. Click **Set Master Password** to open the Master Password dialog box.
4. Click the **Reset** button to open the Reset Master Password dialog box.
5. In the Reset Master Password dialog box, click **Reset Master Password** and click **OK**.

**Note**
Reset of the master password can be used if you forgot your master password or if you would like to clear all the passwords stored in your sessions.
Tab Management

Xshell has a powerful tab management feature. You can connect to multiple hosts and compare them side by side from a single window. The intuitive tab management feature is a unique Xshell feature that cannot be found in other terminal emulators.

Each tab is associated to a single terminal and it belongs to a tab group. A tab group is a collection tabs. A single Xshell window can have multiple tab groups and can be organized as desired.

Tab

There are several ways you can create a new tab. You can use any of the following methods:

- Click the [Tab] menu and select [New Tab]
- Double click on the tab bar in the background.
- Use the keyboard shortcut, Shift + Alt + N.

To close a Tab:
- Click the x button on the tab.
- When focus is on the tab, press Ctrl+Shift+F4.

To close a tab from Terminal:
1. While connected to the remote host, enter ‘exit’.
2. In Xshell’s local shell, type ‘exit’ again.

Note

To close a tab from Terminal, you must not have selected the ‘Revert to local shell when connection is closed’ option in the [Options] dialog box. Also, if the ‘Exit Xshell when the last tab is closed’ option is not selected, you must select ‘Exit’ from the ‘File’ menu to exit Xshell.

Tab Group

A tab group is a collection of multiple tabs. Use tab groups to neatly organize sessions. Only one tab from the tab group is visible at any given moment. To view and compare multiple tabs simultaneously, you must separate the tabs into different groups.

To Create a New Tab Group:
1. Right click on the tab background.
2. Point to [New Tab Group] and select a location you want to create a new tab group.

Note

If you want to create a new tab group with an existing tab, you can drag a tab to edge of the
terminal until you see the blue marker and drop it.

**To Move a Tab to a Different Tab Group:**
1. Select a tab you want to move to a new tab group.
2. While holding down the left mouse button, drag the tab to a different tab group.
3. Drop the tab to a new tab group.

**To Delete a Tab Group:**
1. Select a tab group you want to close.
2. Right click on the tab group in the background.
3. Select the [Close This Tab Group] option.

**To Combine All Tab Groups into one Tab Group**
1. Select the Xshell window you would like to combine tab groups.
2. In the [Tab] menu, select 'Merge All Tab Groups' under 'Arrange.'

**Split and Merge Tabs**

Tabs can be separated to create new windows and you can combine tabs from different windows into one window. To use this feature, you must turn off the 'Use single-process mode for better performance' in [Options > Advanced].

**To Detach a Tab and Create a New Window:**
1. Select the tab you want to detach with the mouse.
2. Drag the tab and drop it outside of the Xshell Window.

**To Detach and Tab and Add it to an Existing Window:**
1. Select the tab from an Xshell Window.
2. Drag the tab and drop it into a tab group of an existing Xshell Window.

**Arrange Tabs**

Multiple tabs can be automatically arranged into horizontal, vertical, or tiled tab groups. This is useful for concurrent operations on multiple servers.

**To Arrange Tabs Horizontally, Vertically, or Tiled:**
1. Select the Xshell window to be arranged.
2. In the [Tab] menu, under ‘Arrange,’ select the desired arrangement method.

**To Combine an Auto-Arranged Group of Tabs into One Tab Group:**
1. Select the Xshell window to be arranged.
2. In the [Tab] menu, under ‘Arrange,’ select 'Merge All Tab Groups.'
**Tunneling Service**

**Xshell** provides TCP/IP and X11 forwarding functions, which creates a secure tunnel between a user’s PC and another computer connected across an unreliable network environment providing a way to safely transmit data.

**TCP/IP Port Forwarding**

To use port forwarding service via a secure tunnel, define port forwarding rules for each application program.

**Note**

For local forwarding, connection to a local PC’s listening port is forwarded to a specific destination host port.

For remote forwarding, connection to the remote host listening port is forwarded to a specific destination host port.

Dynamic forwarding works the same as local forwarding. It automatically determines the host of delivery destination and port according to the SOCKS protocol. The default port number of SOCKS protocol is 1080.

**To Add a New Port Forwarding Rule to a Session:**

1. Open the **Sessions** dialog box.
2. Select a session for which to edit port forwarding rule.
3. Click the standard [Properties] button.
4. Select [Connection > SSH > Tunneling] from [Category].
5. Click [Add] to open the **Forwarding Rule** dialog box.
6. Select connection type from the [Type] list.
7. Enter the localhost or IP address in [Source Host].
8. Enter the port number in [Listening Port] or select a service name.
9. Enter the name of the host or IP address where the server program operates in [Destination Host].
10. Enter the port number where server program is waiting in [Destination Port].
11. Enter a description of the forwarding rule in [Description].
12. Click [OK].

**To Change Forwarding Rule:**

1. Open the **Sessions** dialog box.
2. Select session for which to edit port forwarding rule.
3. Click the standard [Properties] button.
4. Select [Connection > SSH > Tunneling] from [Category].
5. Select a forwarding rule to change.
6. Click [Edit].

---

36 | **Tunneling** Service
To Remove Port Forwarding Rule:
1. Open the **Sessions** dialog box.
2. Select session for which to edit port forwarding rule.
3. Click the standard [Properties] button.
4. Select [Connection > SSH > Tunneling] from [Category].
5. Select a forwarding rule to remove.
6. Click [Remove].

**X11 Forwarding**

X11 forwarding is a special TCP/IP port forwarding case. The X11 protocol is used by a PC X server software, such as Xmanager, and the connection is established to a user PC from a remote host. It is thus the reverse situation from other client programs, such as email or telnet. Using X11 forwarding, remote X11 application programs can be used in a user's PC via a secure encoding tunnel without complicated port forwarding settings.

To use the X11 forwarding service, you should configure both **Xshell** and the SSH server.

**To Activate X11 Forwarding in Xshell:**
1. Open the **Sessions** dialog box.
2. Select a session for which to activate X11 forwarding.
3. Click the standard [Properties] button.
4. Select [Connection > SSH > Tunneling] from [Category].
5. Select [Forward X11 Connections to].
6. If **Xmanager**® is installed in the user’s PC, select [Xmanager]. If another PC X server is used, select [X DISPLAY] and enter an appropriate DISPLAY.
7. Click [OK].

**Note**
In Xmanager, Xshell automatically finds the X DISPLAY option. In other PC X server programs, the option must be set manually. If PC X server uses TCP 6000 port, DISPLAY is set as ‘localhost:0.0’.

**To Activate X11 Forwarding in an OpenSSH Server:**
1. Open the `/etc/ssh/sshd_config` file.
2. Set X11Forwarding option value as follows:
   ```
   X11Forwarding yes
   ```
3. Restart SSH server.

**To Activate X11 Forwarding in an ssh.com Server:**
1. Open the `/etc/ssh2/sshd2_config` file.
2. Set AllowX11Forwarding option value as follows:
   ```
   AllowX11Forwarding yes
   ```
3. Restart SSH server.

Tunneling Service | 37
SOCKS4/5 Dynamic Port Forwarding

Dynamic port forwarding is a method to forward a local network connection to an SSH server, where the destination host and port are automatically determined by the SOCKS protocol. Using dynamic port forwarding, Xshell can operate as a SOCKS proxy server.

To Add New Dynamic Port Forwarding Rule to a Session:
1. Open the Sessions dialog box.
2. Select a session for which to edit port forwarding rule.
3. Click the standard [Properties] button.
4. Select [Connection > SSH > Tunneling] from [Category].
5. Open the Forwarding Rule dialog box by clicking [Add].
6. Select Dynamic (SOCKS4/5) from [Type] list.
7. Enter port number in [Listening Port] or select a service name. The SOCKS proxy server default port is 1080.
8. Click [OK].

Note
For dynamic port forwarding, the destination host and port do not need to be entered.

Instant Tunneling

Instant tunneling enables users to add, remove, suspend, and resume a forwarding rule while a session is connected. The current session tunneling status can be checked in the tunneling pane. To view the tunneling pane, select [Tunneling Pane] from the [View] menu.

To Add Port Forwarding Rule in the Tunneling pane:
1. Click the [Forwarding Rules] tab in the tunneling pane.
2. Right-click on the list.

Note
Newly added rules are applied to the current connection. Unless you save the rules, they are deleted when the connection is closed.

To Remove Port Forwarding Rules from the Tunneling pane:
1. Click the [Forwarding Rules] tab in the tunneling pane.
2. Right-click on a rule to remove from the [Forwarding Rules] list.
3. Select [Remove] from menu.

To Suspend Port Forwarding Rules:
1. Click the [Forwarding Rules] tab in the tunneling pane.
2. Right-click on a rule to suspend from the [Forwarding Rules] list.

**To Retry Port Forwarding Rules:**
1. Click the [Forwarding Rules] tab in the tunneling pane.
2. Right-click on a rule to resume in the [Forwarding Rules] list.
3. Select [Resume] from menu.

- **Note**
  Resume can only be executed for a previously suspended rule.
Terminal Window Operations

**Xshell** provides a succinct and powerful terminal window enabling users to simultaneously use the remote terminal and local prompt command interface. Terminal window provides a range of convenient functions, such as copy & paste, find character string, change font and font color, and advanced terminal options.

### Copy and Paste

#### To Select a Character String:
1. Do one of the following:
   - Press the left mouse button at the starting point of an area to select. While pressing the button, move the mouse to the end of the area to be selected and release the button. The selected character string is displayed in an inverted color.
   - Click the left mouse button at the starting point of an area to select. Move mouse to the end of the area. While pressing Shift key, press the left button once again.
   - Double-click a word to select. The double-clicked word is selected.
   - Triple-click a row to select. The entire row is selected.

#### To Select Character Strings in a Column Unit:
1. Press Alt key.
2. Press the left mouse button at the starting point of an area to select. While pressing the button, move to the end of the area to select and release the button.

#### To Copy Selected Character Strings to the Windows Clipboard:
1. Select a character string to copy.
2. Do one of the following:
   - Click the [Smart Selection] button and select [Copy].
   - Select [Copy] from the [Edit] menu.
   - Click the standard [Copy] button.
   - Press Ctrl+Insert key.
   - If [Copy Selected Texts to the Clipboard Automatically] is set in options, the selected text is automatically copied.

#### To Copy Selected Character String to Notepad:
1. Select a character string to copy.
2. Do one of the following:
   - Click the [Smart Selection] button and select [To Notepad].
   - Point to [To Notepad] in the [Edit] menu and select [Selected Area].

**Note**
The scroll buffer and current screen may be copied as well as the selected character strings. A
notepad window is automatically displayed with the copied text. This does not copy character strings to the clipboard.

To Paste Clipboard Contents to the Terminal Screen:
1. Do one of the following:
   - Click the standard [Paste] button.
   - Press Shift+Insert key.
   - If Paste the clipboard contents is selected for middle or right mouse button operation, click the corresponding mouse button.

To Set Xterm Style Copy and Paste:
1. Open the Options dialog box.
2. Click the [Keyboard and Mouse] tab.
4. Select [Selection] - [Copy Selected Texts to the Clipboard Automatically].
5. Click [OK].

Note
When a character string is selected, the xterm program copies it to clipboard. When the middle mouse button is pressed, it is pasted to the terminal screen.

Find String
Search scroll buffer using a specific keyword or a regular expression.

To Find with Keyword:
2. Enter a keyword in Find dialog box.
3. Click [Find Next].

To Find with Regular Expression:
2. Enter a keyword in Find dialog box.
3. Select [Regular Expression].
4. Click [Find Next].

Note
For detailed information on regular expression, see 'Regular Expression'.

Font Change
In the terminal screen, characters must be displayed in rows and columns. In Xshell, only fixed width fonts may be selected.
To Change Terminal Font and the Font Size:
1. Do one of the following:
   - Click the standard [Fonts] button and select a font and the font size.
   - Select [Appearance] in Session Properties dialog box and select a font and the font size.

To Change Bold Text:
1. Open the Session Properties dialog box.
2. Select [Appearance] from [Category].
3. Select an option from [Bold] field.

   Note
   As for Bold, either colors or bold font or both may be used.

Font Color and Background Color Setting
In a color scheme, font colors, background colors and ANSI 16 colors are saved. Xshell enables users to select/change color schemes anytime while using Xshell. The selected color scheme is applied immediately.

To Change Terminal Color:
1. Do one of the following:
   - Click the standard [Color Schemes] button to display the Select Color Scheme dialog box. Select a color scheme in the dialog box and click [OK].
   - Select [Appearance] from [Category] in Session Properties dialog box, select a color scheme from the [Color Scheme] and click [OK].

   Note
   Xshell provides several default color schemes. Users may edit the existing color schemes or create new color schemes.

To Create New Color Scheme:
1. Open the Select Color Scheme dialog box.
2. Click [New]. A new color scheme is added to the list.
3. Select the new color scheme created.
4. Click [Edit]. Edit Color Scheme dialog box is displayed.

To Edit Color Scheme:
1. Open the Select Color Scheme dialog box.
2. Select a color scheme to edit.
3. Click [Edit]. Edit Color Scheme dialog box is displayed.
4. Select colors for normal text in [Normal Text].
5. Select colors for bold text in [Bold Text]. In general, colors lighter than the normal text are used for bold text.
6. [ANSI Colors] is used to express ANSI color code in terminal. The colors on top are for normal
text, such as black, red, green, yellow, blue, magenta, cyan and white, and the colors on the bottom are for bold text.

**To Export Color Scheme:**
1. Open the Select Color Scheme dialog box.
2. Select a color scheme to export.
3. Click [Export]. **Save** dialog box is displayed.
4. Select a folder and enter the file name to save.
5. Click [Save].

■ **Note**
Exported file is in `.xcs` format and may be used in Xshell only. A number of color schemes may be saved in a single file. The color scheme names are also saved in the file.

**To Import Color Scheme:**
1. Open the Select Color Scheme dialog box.
2. Click [Import]. **Open** dialog box is displayed.
3. Select a color scheme file (.xcs) to import.
4. Click [Open].

**Cursor Change**

**To Change Cursor Color:**
1. Open the Session Properties dialog box.
2. Select [Appearance] from [Category].
5. Click [OK].

**To Change Cursor Blinking:**
1. Open the Session Properties dialog box.
2. Select [Appearance] from [Category].
3. Select or deselect [Use blinking cursor].
4. Click [OK].

**To Change Cursor Blinking Speed:**
1. Open the Session Properties dialog box.
2. Select [Appearance] from [Category].
3. Check [Use blinking cursor].
4. Enter cursor blinking speed by millisecond in [Speed].
5. Click [OK].
Window Handling

To Minimize to Notification Area:
1. Open the Options dialog box.
2. Click the [Advanced] tab.
4. Save changes by clicking [OK].

To Minimize to Notification Area at Startup:
1. Open the Options dialog box.
2. Click the [Advanced] tab.
3. Check [Minimize to the notification area at Xshell startup] in [Window] options.
4. Save changes by clicking [OK].

To Exit Xshell when All Connections are Closed:
1. Open the Options dialog box.
2. Click the [Advanced] tab.
3. Check [Exit Xshell when all connections are closed] in [Session] options.
4. Click [OK].

To Exit to Local Shell when Connections are Closed:
1. Open the Options dialog box.
2. Click the [Advanced] tab.
3. Check [Revert to local shell when connection is closed] in [Session] options.
4. Click [OK].

To Create New Xshell Window:

To Move to Another Xshell Window:

Note
The same function may be executed using Alt+Right and Alt+Left keys.

To Close All Xshell Windows Simultaneously:
1. Select [Close All] from the [Window] menu.

To Close All Xshell Windows Except the Current Window:
1. Select [Close All but This] from the [Window] menu.

Multi-session Handling

‘Multi-session’ enables users to work and move between sessions using the sessions tab or
sessions bar while maintaining multiple connections in a single Xshell window.

To Open the Multiple Sessions in Single Xshell Window:
1. Open the Options dialog box.
2. Click the [Advanced] tab.
4. Save changes by clicking [OK].

To Create a New Connection in Sessions Tab:
1. Click the [+ (Add Tab)] button at the far left of the sessions tab.
2. Select one from sessions list. The selected session is opened in a new tab.

To Create New Connection in Sessions Bar:
1. Click an icon at the far left of the sessions bar.
2. Select one from the sessions list. The selected session is opened in a new tab.

Note
To create a new connection, use a session as described in ‘Session Management’ or try a connection without a session.

To Connect with a Remote Computer by Entering a Command in Local Shell:
1. To open a local shell, click the [+ (Add Tab)] button of the sessions tab and select [Local Shell] or double-click a blank in the sessions tab.
2. In the local command prompt, connect to a remote computer using commands, such as ssh, telnet and sftp. For details on using command, enter ‘?’.

Note
For detailed information on local commands, see ‘Xshell Local Command’.

To Move Between Sessions at Multi-session Connection:
1. Do one of the following:
   • Click a sessions tab.
   • Click a session button from the sessions bar.
   • Use Ctrl+Tab, Shift+Tab or Ctrl+Shift+Tab.
   • Move between sessions using Alt+‘session number’.

To Connect with Session in New Xshell Window:
1. Select [New Terminal] from the [Window] menu or click the standard [New Terminal] button. A new Xshell window opens and connection is attempted with the same session information as the currently connected session.

Quick Command Sets Setting
By designating frequently used character strings as quick commands, Users can avoid repeated keyboard inputs and use simple mouse clicks to execute the commands. To display quick commands bar, check [Quick Commands] in the [View] menu.
To Add Quick Command Set:
2. Click [New].
3. Enter the new quick command set name.

Note
To open the Quick Command Sets dialog box, click the [Quick Command Set] button (an icon at the far left) in the quick commands bar and select [Browse] from the list.

To Add Quick Command on Quick Commands Bar:
1. Click an undefined Quick Command button in the quick commands bar or press a shortcut key (Ctrl+F1, etc.). Edit Quick Command dialog box is displayed.
2. Enter the quick command name in [Label] and a frequently used command or character string in [Action] area.
3. Click [OK].

Note
To edit the quick command set displayed in the quick commands bar, click the [Quick Command Set] button (an icon at the far left) on the bar and select [Edit] from the list. Edit Quick Command Set dialog box is displayed.

The order of quick commands listed in the quick command bar can be changed by dragging button.

To Add Quick Command to Quick Command Set:
2. Select a quick command set to which a quick command is to be added.
3. Click [Edit]. Edit Quick Command Set dialog box is displayed.
4. Select a quick command and click [Edit]. Edit Quick Command dialog box is displayed.
5. Enter the quick command name in [Label] and a frequently used command or character string in [Action] area.

Note
You can use the %HOSTNAME variable to pass the host name of your PC. For example, if the host name for your PC is ‘COMPUTER_A’, then if you use ‘echo %HOSTNAME’, ‘echo COMPUTER_A’ will be sent.

6. Click [OK].
7. To add more quick commands, repeat the process from 4 to 6.
8. Click [OK] in Edit Quick Command Set dialog box.

Note
In Edit Quick Command Set dialog box, add, delete, and edit quick commands. The order of
quick commands listed in the quick command bar may be changed.

**To Display Another Quick Command Set in Quick Commands Bar:**
1. Click the [Quick Command Set] button (an icon at the far left) in quick commands bar and select a quick command set from the list. The buttons from the selected quick command set are listed.

**To Select Quick Command Set Displayed when Session is Started:**
1. Open the session’s **Session Properties** dialog box.
2. Select [Advanced] from [Category].
3. Select a quick command set to be used in session.
4. Press [Browse] and select the quick command set or create a new quick command set in **Quick Command Sets** dialog box.
5. Click [OK].

**Terminal Output Encoding Change**

**Xshell** uses the default user language in Windows system. Users can select and use various encodings which differ from the Windows system according to remote host encoding.

**To Change Session Encoding:**
1. Do one of the following:
   - Click the standard [Encoding] button and select an encoding to use.
   - Open the **Session Properties** dialog box and select [Terminal] from [Category] and select an encoding from the [Encoding] list.
2. Display UTF-8 Encoding:
   - If a remote computer is set to support unicode (UTF-8) and to use UTF-8, use ‘Unicode (UTF-8)’ as encoding. UTF-8 encoding enables simultaneous output of character sets in various languages.

**Note**
To correctly display the selected encoding, the selected encoding language pack must be installed in the Windows system concerned.

Encoding option does not change keyboard input values. If necessary, install the appropriate IME (Input Method Editor) provided by Windows.

**Advanced Terminal Options Setting**

**To Change Scroll Buffer Size:**
1. Open the **Session Properties** dialog box.
2. Select [Terminal] from [Category].
3. Enter number of rows to use in [Scroll Buffer].
4. Click [OK].
Note

Scroll buffer size is a value between 0 and 2,147,483,647. 0 means that scroll buffer is not used.

To Change Terminal Type:
1. Open the **Session Properties** dialog box.
2. Select [Terminal] from [Category].
3. Select a terminal type from [Terminal Type].
4. Click [OK].

To Change Size at Terminal Startup:
1. Open the **Session Properties** dialog box.
2. Select [Terminal] from [Category].
3. Check [Use the following terminal size when connected] from the [Emulation] area.
4. Enter column size in [Columns].
5. Enter row size in [Rows].
6. Click [OK].

To Change Keypad Mode:
1. Open the **Session Properties** dialog box.
2. Select [Terminal > VT Modes] from [Category].
4. Click [OK].

**Layout Management**

Layout management enables users to save Xshell window layout according to their preference. In **Manage Layout** dialog box, change names or delete the saved layouts.

To Save Layout of the Current Xshell Window:
1. Select [Layout] from the [View] menu and select [Save As].
2. Enter [New name] in **Save As** dialog box.
3. Click [OK].

To Change Xshell Window to Another Layout:
- Select [Layout] from the [View] menu and select one from the layouts list.
- Press Alt+L to select one from the layouts list.

To Manage Registered Layouts List:
1. Select [Layout] from the [View] menu and select [Manage].
2. Delete the layout or rename it in **Manage Layout** dialog box.

**Highlight Sets Settings**

Strings you’d like to emphasize can be highlighted via color or font changes using Xshell’s Highlight Sets.
To Add a Highlight Set:
1. From the [Tools] menu, select [Terminal Highlight Sets] to open the Highlight Sets dialog box.
2. Click [New] to create a new Highlight Set.
3. Enter the name for the new Highlight Set.

**Note**
You can also open the Highlight Sets dialog box using the Terminal Highlight Sets button on the standard toolbar.

To Delete a Highlight Set:
1. From the [Tools] menu, select [Terminal Highlight Sets] to open the Highlight Sets dialog box.
2. Select the Highlight Set to delete and click [Delete].

To Apply a Highlight Set to a Session:
1. From the Highlight Sets Dialog box, select the desired Highlight Set.
2. Click [Set to Current].

**Note**
Highlight Sets can also be applied to sessions from a session’s properties.

To Add Keywords to a Highlight Set:
1. From the Highlight Sets Dialog box, select the desired Highlight Set.
2. Click [Add] to open the Keyword dialog box.
3. Enter the keyword to highlight. To distinguish between upper/lower case, select the ‘Case Sensitive’ option. To highlight strings based on regular expressions, select the ‘Regular Expression’ option.
4. Select the style of the highlight in the ‘View’ area. To change the color of the text without changing the background color, select the ‘Term Color’ option.
5. Click [OK].

To Delete Keywords from a Highlight Set:
1. From the Highlight Sets Dialog box, select the Highlight Set which contains the keyword.
2. Select the keyword to delete.
3. Click [Delete]

To Modify Keywords in a Highlight Set:
1. From the Highlight Sets Dialog box, select the Highlight Set which contains the keyword.
2. Select the keyword to modify.
3. Click [Edit] to open the keyword dialog box.
4. After completing your modification, click [OK].
Options Setting

In the Options dialog box, set global options applied to all sessions. The dialog box may be opened by selecting [Options] in the [Tools] menu.

Session Folder and Startup Session

The Xshell session folder path can be changed. In the Sessions dialog box, all sessions of the changed path are displayed. Select a network folder to share sessions with other users.

To Change Session Folder:
1. Open the Options dialog box.

To Register Sessions to Open at Startup:
1. Open the Options dialog box.
2. Click [Add] under the [Sessions to open at startup] list in the [General] tab.
3. Select a session file from Open dialog box.

History Clearing and Connection Log

In Clear History dialog box, clear history of address bar, compose bar, search keyword, local shell and connection log. In History Settings dialog box, designate a file to save connection log settings.

To Clear History:
1. Open the Options dialog box.
3. Select contents to clear from Clear History dialog box.
4. Click [Clear].

To Save Connection Log:
1. Open the Options dialog box.
2. Click the [Log] tab.
3. Select [Log connection information on the following file.] from Connection Log area.
4. Enter a file to save information about connection server, connection protocol, connection time, exit time and connection time.

Key Mapping Setting

In Custom Key Mapping dialog box, currently set shortcut key combinations are listed. The user can add, delete, and edit key combinations.

To Change Key Mapping:
1. Open the Options dialog box.
2. Click the [Keyboard and Mouse] tab.

3. Click [Edit] in [Key Mapping]. **Custom Key Mapping** dialog box is displayed.

4. Select a key combination to change from [Current Key Setting] and click [Edit].

5. Select one from **Menu**, **Send String**, **Run Script** or **Launch Application** in [Type].

6. Enter the selected menu or character string in [Action].

7. Click [OK].

**Mouse Setting**

The middle and right mouse button actions can be individually selected. The delimiters to be used when selecting a word by double-clicking can be designated.

**To Change Mouse Button Operation:**
1. Open the **Options** dialog box.
2. Select one of the middle mouse button actions from the [Keyboard and Mouse] tab.
   - Do nothing.
   - Open the popup menu.
   - Paste the clipboard contents (default value).
   - Open Properties dialog.
3. Select one of the right button actions. The default action is [Open the popup menu].

**To Change Delimiter for Selection by Double-clicking:**
1. Open the **Options** dialog box.
2. Enter a delimiter to use when selecting a word in the [Keyboard and Mouse] tab [Selection] field.

**Transparency Setting**

**Xshell** offers a transparency setting.

**To Set Window to Appear Transparent:**
2. Open the **Options** dialog box.
4. Set [Opacity]. The smaller the opacity is, the more transparent the **Xshell** window becomes.
5. If [Make window opaque on mouse over] option is selected, **Xshell** window is displayed opaque while mouse is over the window even when it is set to display **Xshell** window transparent.
6. If [Always on Top when it is transparent] option is selected, **Xshell** window is displayed at the top of all windows.

**Master Password Settings**

Master password can be used to save passwords more securely using the user defined master password.

Master password uses a user defined keyword to encrypt the password section of the session data.
When the master password is enabled, Xshell asks for the master password every time a new
Xshell instance is started and a session is open. If the correct master password in not inputted, the
session’s password is not able to be utilized and must be entered again manually preventing
unauthorized access.
For details on Master Password setting, see 'Master Password'.

**Screen Lock Settings**

You can lock the terminal screen while you are away from the PC to protect your session from
unwanted use. When the terminal is locked, the terminal screen changes to a grey and users
cannot interact with terminal until the correct password is received. Once the screen is locked, you
cannot pass any data to the terminal. Xshell cannot be closed until the correct password is
received. However, connections will stay open and data will be still updated in the terminal.

**Set a Screen Lock Password**

1. From the **Tools** menu, select **Options**.
2. Select the **Security** tab.
3. From the **Lock Screen** section, click **Set Password** to open the Lock Screen Password dialog
   box.
4. Enter the desired password into the ‘Enter Password’ and ‘Confirm Password’ fields.
5. Click **OK** to save.

   **Note**
   If a Lock Screen is attempted from the **View** menu when a password is not set, the user will
   be prompted to first set a password.

**To Lock Screen**

1. Click on the **View** menu and select **Lock Screen**.

   **Note**
   If a Lock Screen is attempted from the **View** menu when a password is not set, the user will
   be prompted to first set a password.

**Auto Lock**

**Auto Lock** can be used to lock the terminal screen automatically after a duration of no interaction
with the terminal. This feature is especially useful if you are using your computer in an open area.

**To Enable Auto Unlock**

1. Click on the **Tools** menu and then select **Options**.
2. Click on the **Security** tab.
3. In the Screen Lock section, select the **Automatically lock screen** option.
4. Enter the number of minutes Xshell should wait for terminal input/output before the screen is
   locked automatically.
Note
If a Lock Screen is attempted from the View menu when a password is not set, the user will be prompted to first set a password.

5. Click OK to save.

**Live Update Settings**
Live update allows Xshell to check for software update at an interval defined by the user. By default, it checks for a new update every 2 weeks. When the [Check for updates automatically] option is enabled, Xshell checks for the updates with NetSarang’s server upon startup.

**To Enable Live Update**
1. Click on the Tools menu and then select Options.
2. Click on the Update tab.
3. Select the Check for updates automatically option.
4. Enter the number of days you want to wait until Xshell checks for updates again.
5. Click OK to save the changes.

Note
You can always check for updates manually by selecting the Check for Updates in the Help menu.

**Advanced Settings**
Advanced options can be set in the Options dialog box [Advanced] tab.

*Switch to English input when ESC key is pressed*
When ESC key is pressed to move to command mode while entering Korean in certain applications, such as vi and vim, the status is automatically changed to English input mode.

*Use the Smart select button for easy copy and file download*
Show or hide the [Smart Selection] button when selecting a terminal area with a mouse.

*Minimize to the notification area*
When Xshell is minimized, it is minimized to the notification area.

*Show session tab in full screen mode*
Show the sessions tab in full screen mode.

*Hide scroll bar in full screen mode*
Hide the scroll bar in full screen mode.

*Use the title bar in full screen mode*
This hides the control window which normally appears in full screen mode. To exit full screen mode, the shortcut key or terminal context menu must be used.
Arrange cascade windows in current window size
Uses the current window size to cascade Xshell windows. When this option is not selected, Xshell windows are cascaded in default size.

Run Xshell at Windows startup
Xshell is automatically started when Windows is started.

Minimize to the notification area at Xshell startup
Minimize to the notification area when Xshell is started.

Open the Sessions dialog box at Xshell startup
Open the Sessions dialog box when Xshell is started.

Use Alt key to access menu
Open the menu by pressing Alt key.

Open multiple sessions in a single Xshell window
Opens multiple sessions in a single Xshell window. Move between sessions using the session tab or session bar. If this option is not enabled, each session will open in a separate window when opening multiple sessions simultaneously.

Confirm to disconnect when Xshell is terminated
Ask whether or not to terminate connected sessions when a program is terminated.

Confirm to disconnect when session is terminated
Ask whether to disconnect at session termination.

Revert to local shell when connection is closed
The session tab is maintained in local shell status when a connection is closed. In a local shell session, the Xshell prompt is displayed in terminal screen and local commands, such as open, telnet, ssh and ping can be executed. To view a list of commands, execute help or ? in the Xshell prompt.

Clear scrollback buffer when connection is closed
When a connection is closed, the scrollback buffer will be cleared.

Restore the last used tab group layout at Xshell startup
If Xshell is closed normally or abnormally, upon next startup Xshell will revert back to session connection status as well as the tab arrangement state of Xshell before it was closed.

Auto-save session changes to current session file
When changes are made to the session properties by the user, the changed are automatically saved in the session file. In the case of the default session, the changes are saved to the default session file.

Use single-process mode for better performance
Xshell’s tabs can each have their own process (multi-process mode) or multiple tabs can run on the same process (single process mode). Single-process mode consumes less system resources and can improve performance, but tabs cannot be split to new windows and cannot be combined into one window.

**[New File Transfer] opens an SFTP session in Xshell, not executing Xftp**

Selecting [New File Transfer] from the [Window] menu opens an SFTP session in Xshell instead of opening Xftp even if Xftp is installed on the computer. If the Xftp program is not installed, the SFTP session ignores this option.

**Exit Xshell when all tabs are closed simultaneously**

If this option is not enabled, Xshell will not exit even if all tabs are closed simultaneously. Instead, a local session will begin to run.

**Exit Xshell when the last tab is closed**

If this option is not enabled, Xshell will not exit even if the last tab is closed. Instead, a local session will begin to run.
File Transfer

Xshell allows sending or receiving files using FTP/SFTP and the X/Y/ZMODEM protocols.

File Transfer Using SFTP

SFTP is an SSH-based file transfer protocol. Compared to FTP, X/Y/ZMODEM, it supports a safer and faster file transfer.

To Receive Files with SFTP:
1. Connect with a host from which to receive a file using the `sftp` command in the local prompt.
   
   ```bash
   [C:\~]$ sftp hostname
   ```

2. Receive a file using `get` command in the sftp prompt.
   
   ```bash
   sftp:/home/user21> get filename
   ```

   **Note**
   For a detailed description of the sftp command supported by Xshell, run the help command at the sftp command prompt.

To Send Files with SFTP:

1. Connect with a host to which to send a file using the `sftp` command in the local prompt.
   
   ```bash
   [C:\~]$ sftp hostname
   ```

2. Send a file using `put` command in the sftp prompt.
   
   ```bash
   sftp:/home/user21> put filename
   ```

   **Note**
   For a detailed explanation of the sftp command supported by Xshell, run the help command at the sftp command prompt.

File Transfer Using FTP

Xshell supports the FTP file transfer protocol on a terminal basis.

To Receive Files with FTP:
1. Connect with a host from which to receive a file using the `ftp` command in the local prompt.
2. Receive a file using **get** command in the ftp prompt.

```
sftp://home/user21> get filename
```

**Note**
For a detailed explanation of the ftp command supported in Xshell, run the help command at the ftp command prompt.

### To Send Files with Ftp:

1. Connect with a host to which to send a file using the **ftp** command in the local prompt.

```
[C:\~]$ ftp hostname
```

2. Send a file using **put** command in the ftp prompt.

```
ftp://home/user21> put filename
```

**Note**
For a detailed explanation of the ftp command supported in Xshell, run the help command at the ftp command prompt.

---

**File Transfer Using X/Y/ZMODEM**

Files transferred via X/Y/ZMODEM are saved in a folder designated by a user. Users may designate different folders each time files are received. The method for file transfers using XMODEM and YMODEM is similar to ZMODEM. The commands you use to send and received files fore X,Y, and ZMODEM are sx, sb, sb for receiving and rx, rb, rz for sending respectively. The commands may differ between systems and it is recommend that users consult the remote OS’s manual. Below is a description of the average ZMODEM file transfer.

### To Receive File with ZMODEM:

1. Execute the following command in a remote host prompt:

```
$ sz file1 file2 ...
```

**Note**
If [Activate ZMODEM automatically] is set in the Session Properties, the file receive process will be started automatically, and the following process in No. 2 and 3 can be omitted.

3. Select [Receive with ZMODEM].

**Note**
If the sz command does not exist in a remote host, users must install it directly. In most cases,
similar commands exist.

**To Receive File with ZMODEM in Xshell Terminal:**
1. Select the name of a file to download in the Xshell terminal window. The [Smart Selection] button is displayed around the selected file name.
2. Click the [Smart Selection] button.
3. Select [Download with ZMODEM].

**To Send File with ZMODEM:**
1. Execute the following command in remote prompt:
   
   ```bash
   $ rz
   ```
   
   **Note**
   If [Activate ZMODEM automatically] is set in the Session Properties, the file send process will be started automatically, and the following process in No. 2 and 3 can be omitted.

3. Select [Send with ZMODEM].
4. Select a file to send from the Open File dialog box.
5. To send a file as ASCII, select [Send File as ASCII].
6. Click [Open].

**To Send File with ZMODEM Using Drag & Drop:**
1. Select a file to upload from the Windows file explorer.
2. Drag the file and drop it in Xshell terminal window. File transfer is carried out automatically.

**To Change Default Folder to Save File:**
1. Open the Session Properties dialog box.
2. Select [File Transfer] from [Category].
3. Select [Use the following download path] from [Receive folder].
4. Open the Browse For Folder dialog box by clicking [...] button of the [Download Path] and select a folder where the received files are to be saved.
5. Click [OK].

**To View Files Received in the Default Path:**
1. Open the Session Properties dialog box.
2. Select [File Transfer] from [Category].

**File Transfer Using Xftp**

Xshell is interoperable with Xftp, a NetSarang Computer Inc. file transfer program. This allows for fast and convenient FTP/SFTP connections with a host currently connected with Xshell.
To Create a Xftp Connection with a Host Currently Connected via Xshell:

1. Connect with the host of a file to be transferred using Xshell.

**Note**
If a protocol Xshell uses is SSH, Xftp attempts an SFTP connection. If the protocol used by Xshell is TELNET or RLOGIN, Xftp attempts an FTP connection.
Session Logging and Tracing

Xshell allows users to log the entire transcript of a session to a file. Trace may be used for debugging.

Session Logging

To Log Character Strings Only:
2. Select [Start]. Save As dialog box is displayed.
3. Enter the file name where log data is to be saved.
4. Clear [Record terminal code as well as normal text].
5. Click [Save].

Note
Logging continues until a session ends. To stop logging without ending a session, select [Stop] from the [File] – [Log] menu. Files with different names in the Save As dialog box are file formats which were specified the the logging options of a session’s properties.

To Log Character Strings with Terminal Codes:
2. Select [Start]. Save As dialog box is displayed.
3. Enter the file name where log data is to be saved.
4. Check [Record terminal code as well as normal text].
5. Click [Save].

To Start Logging at Session Connection:
1. Open the Session Properties dialog box.
2. Select [Advanced > Logging] from [Category].
3. Select [Start logging upon connection].
4. Designate the folder or file name where the log is to be saved.
5. Click [OK].

Session Tracing

Using the trace option, trace protocol control data is exchanged with a remote host.
For SSH protocols, user authentication and algorithm exchange details may be displayed on the terminal screen. For TELNET protocols, the exchange of various options can be traced. This is useful when problems occur in connection with a remote host.

To Turn on or Turn off Trace Function:
1. Open the Session Properties dialog box.
2. Select [Advanced > Trace] from the [Category].
3. Select options appropriately.
4. Click [OK].
Printing

Xshell provides the ability to print text in a terminal window via a local printer. Xshell uses fonts and colors used in a terminal window for printing. The printing paper margins can be set in the Page Setup dialog box.

To Set Paper Size and Direction:
2. Select an appropriate paper size and direction.
3. Enter margins.
4. Click [OK] to save changes.

To Print:
2. Select printer from the [Name] list.
3. Click [OK].
Using Xagent

Xagent is an SSH authentication agent. Xagent holds a user key for public key user authentication and provides it to Xshell when a user key is required by Xshell.

Xagent retains all user key lists and requests a passphrase input when necessary. When a user enters a passphrase, Xagent decodes the user key and saves it in memory. Via Xagent, users may use the same key several times by entering the passphrase once.

Xagent also works as an SSH authentication server for the SSH agent forwarding feature. You must use the SSH agent forwarding feature when connecting to a different remote host from the first remote host. Typically, your private key is only held in your local PC and an SSH client program on the first server cannot connect to a second machine. However, using the SSH agent forwarding feature, the SSH client program on the first server requests a private key from Xagent to enter into the second server.

Note
When Xagent is executed, the Xagent icon is created in the notification area. Even when the Xagent dialog box is closed, Xagent is not closed and keeps running. To close Xagent or open the Xagent dialog box, use the icon menus in the notification area.

Connecting to a Server Through Xagent

To Set Xshell to Use Xagent:
1. Open the Session Properties dialog box.
2. Select [Connection > SSH] from [Category].
3. Select [Use Xagent (SSH agent) for handling passphrase].
4. Click [OK].

To Connect with SSH Server Through Xagent:
1. Set Xshell to use Xagent.
2. Execute Xagent if Xagent is not running.
3. Connect to SSH server.
   - In this case, the SSH server must support public key user authentication and the public key section of the user key must be registered on the server.
4. Passphrase dialog box is displayed. Enter passphrase of the selected user key.

Note
When selecting [Launch Xagent automatically] in [Connection > SSH] setting, the process in No. 2 above may be omitted. Passphrase dialog box is displayed only when the selected key status is Close. You can check user key status in Xagent user keys list.

Note
Xshell will attempt to authenticate into the server by cycling through the keys managed by Xagent. Because multiple attempts may need to be made before a key match is found, authentication may fail if the number of attempts exceeds the server’s defined limit. In this
case, the number of allowable authentication attempts can be increased on the server or the number of keys must be adjusted in Xagent.

**Using the Xagent User Key on a Remote Host**

Using **Xagent**, the SSH client on a remote host can use a user key used by **Xshell**, which is a user key held by **Xagent**. To use an **Xagent** user key on a remote host, both **Xshell** and the remote host SSH server must support agent-forwarding.

**To Activate Agent-Forwarding on the ssh.com Server:**

1. Open the `/etc/ssh2/sshd2_config` file.
2. Set value for `AllowAgentForwarding` option as follows:

   ```
   AllowAgentForwarding yes
   ```
3. Restart SSH server.

   **Note**
   OpenSSH servers automatically enable the agent forwarding feature unless user specifies the `no-agent-forwarding` option.

**To Use Xagent Key on the Remote Host:**

1. Set **Xshell** to use **Xagent**.
2. Execute **Xagent** if **Xagent** is not running.
3. Connect to SSH server and login.

   **Note**
   If the SSH server supports the agent forwarding feature, the environment variable for agent forwarding (SSH_AUTH_SOCK or SSH2_AUTH_SOCK) is set to a proper value.

4. Connect to another server, which supports public key authentication, from the remote server.
5. When **Passphrase** dialog box is displayed, enter passphrase to the selected user key.

   **Note**
   **Passphrase** dialog box is displayed only when the selected key status is **Close**. You can check user key status in **Xagent** user keys list.
Using Scripts

Script is a file that contains a set of commands to be executed at once. Repetitive tasks are conveniently collected in a file and commands may be executed without needing to type them in one by one. Xshell supports Visual Basic Script, JavaScript, and Python Script.

Script Starting and Ending

To Start a Script File:
1. Point to [Script] in the [Tools] menu and select [Run]. Open dialog box is displayed.
2. Select a script file.
3. Click [OK].

To Stop Script File Execution:
1. Point to [Script] in the [Tools] menu and select [Cancel].

Script API

Xshell provides the following script APIs. Use the APIs to automate repetitive tasks.

xsh.Session

The following functions and variables can be used in Xshell sessions. To use these functions and variables, execute them together with xsh.Session. For example, to use ‘Sleep()’ function, use ‘xsh.Session.Sleep(1000)’.

<table>
<thead>
<tr>
<th>Functions</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Return Value</strong></td>
<td><strong>Function</strong></td>
</tr>
<tr>
<td>Void</td>
<td>Open(LPCTSTR lpszSession)</td>
</tr>
<tr>
<td></td>
<td>A character string of an Xshell session path or URL format of Xshell.</td>
</tr>
<tr>
<td></td>
<td>Open a new session or URL. To open a session, place /s option in front of a character string.</td>
</tr>
<tr>
<td></td>
<td>Ex.) To open the A.xsh session, use '/s $PATH/A.xsh'.</td>
</tr>
<tr>
<td>Void</td>
<td>Close()</td>
</tr>
<tr>
<td></td>
<td>Close the currently connected session.</td>
</tr>
<tr>
<td>Void</td>
<td>Sleep(long timeout)</td>
</tr>
<tr>
<td></td>
<td>Timeout</td>
</tr>
<tr>
<td></td>
<td>Milisecond unit time value.</td>
</tr>
<tr>
<td></td>
<td>Make Xshell wait for the designated time.</td>
</tr>
<tr>
<td>Void</td>
<td>LogFilePath(LPCTSTR lpszNewFilePath)</td>
</tr>
<tr>
<td></td>
<td>lpszNewFilePath</td>
</tr>
<tr>
<td></td>
<td>File name including path</td>
</tr>
<tr>
<td></td>
<td>Designate log file.</td>
</tr>
<tr>
<td>void</td>
<td>StartLog()</td>
</tr>
</tbody>
</table>
|                   | Start logging for a session. Log is designated with a path specified in LogFilePath(). If a
void StopLog()
Stop logging.

### Variable

<table>
<thead>
<tr>
<th>Name</th>
<th>Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Connected</td>
<td>BOOL</td>
<td>Check whether current session is connected.</td>
</tr>
<tr>
<td>LocalAddress</td>
<td>BSTR</td>
<td>Retrieve the local address.</td>
</tr>
<tr>
<td>Path</td>
<td>BSTR</td>
<td>Retrieve the current session file path.</td>
</tr>
<tr>
<td>RemoteAddress</td>
<td>BSTR</td>
<td>Retrieve the remote address.</td>
</tr>
<tr>
<td>RemotePort</td>
<td>long</td>
<td>Retrieve the remote port.</td>
</tr>
<tr>
<td>Logging</td>
<td>BOOL</td>
<td>Check whether current session is recording log file.</td>
</tr>
<tr>
<td>LogFilePath</td>
<td>BSTR</td>
<td>Save as a log file.</td>
</tr>
</tbody>
</table>

### xsh.Screen

The following functions and variables can be used when handling of the Xshell terminal screen. To use these functions and variables, execute them together with the xsh.Screen. For example, to use 'Clear()' function, use 'xsh.Screen.Clear()'.
### Variable

<table>
<thead>
<tr>
<th>Name</th>
<th>Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>CurrentColumn</td>
<td>long</td>
<td>Return the current column.</td>
</tr>
<tr>
<td>CurrentRow</td>
<td>long</td>
<td>Return the current row.</td>
</tr>
<tr>
<td>Columns</td>
<td>long</td>
<td>Retrieve the total columns same as terminal width.</td>
</tr>
<tr>
<td>Rows</td>
<td>long</td>
<td>Retrieves the total row same as terminal lines.</td>
</tr>
<tr>
<td>Synchronous</td>
<td>BOOL</td>
<td>Set screen synchronization (True means synchronize and false means do not synchronize)</td>
</tr>
</tbody>
</table>

### Xsh.Dialog

You can use this to manipulate the Xshell terminal screen. To use the following function and variable, execute it with xsh.Dialog. For example, if you want to use the MsgBox() function, append xsh.Dialog.MsgBox() in the front like this: xsh.Dialog.MsgBox().

### Functions

<table>
<thead>
<tr>
<th>Return Value</th>
<th>Function</th>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Long</td>
<td>MsgBox(LPCTSTR lpszMsg)</td>
<td>lpszMsg</td>
<td>Open a message box.</td>
</tr>
<tr>
<td>string</td>
<td>Prompt(LPCTSTR lpszMessage, LPCTSTR lpszTitle, LPCTSTR lpszDefault, BOOL bHidden)</td>
<td>lpszMsg</td>
<td>String you want to send.</td>
</tr>
</tbody>
</table>

### Script Example

```
Sub Main

' *** Connect the session ***
xsh.Session.Open "ssh://192.168.1.17"
' "'/s C:\Users\Administrator\AppData\Roaming\NetSarang\Xshell\Sessions\example.xsh"
xsh.Screen.Synchronous = true
```
xsh.Screen.WaitForString "login: 
"  
xsh.Screen.Send "username"
  
xsh.Screen.Send VbCr
  
xsh.Session.Sleep 100

xsh.Screen.WaitForString "Password: 
"  
xsh.Screen.Send "password"
  
xsh.Screen.Send VbCr
  
xsh.Session.Sleep 100

' *** Wait for Prompt Message ***
xsh.Screen.WaitForString "username@password"

' *** Set File Format ***
Dim app, wb, ws
Set app = CreateObject("Excel.Application")
Set wb = app.Workbooks.Add
set ws = wb.Worksheets(1)

xsh.Session.LogFilePath = "c:\example.log"
xsh.Session.StartLog

Dim waitStrs
waitStrs = Array(Chr(10), "username@password") ' make wait message as array

Dim row, screenrow, readline, itmes
row = 1

' *** Send Command ***
xsh.Screen.Send "cat /etc/passwd"
  
xsh.Screen.Send VbCr
  
xsh.Session.Sleep 100

Dim result

' *** Read Data and Save it as an EXCEL File ***
Do
  While true
    result = xsh.Screen.WaitForStrings(waitStrs, 1000)

    If result = 2 Then
      Exit Do
    End If

    screenrow = xsh.Screen.CurrentRow - 1
    readline = xsh.Screen.Get(screenrow, 1, screenrow, 40)
    itmes = Split(readline, ":", -1)
ws.Cells(row,1).Value = items(0)
ws.Cells(row,2).Value = items(2)

row = row + 1
Wend
Loop

wb.SaveAs("C:\chart.xls") ' save file path
wb.Close
app.Quit

Set ws = nothing
Set wb = nothing
Set app = nothing

xsh.Screen.Synchronous = false
xsh.Session.StopLog

End Sub

References
This section provides referential information about using Xshell.

Standard Buttons
Xshell provides standard buttons for the frequently used tasks and commands.
The following are descriptions of the standard buttons.

<table>
<thead>
<tr>
<th>Button</th>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>![New]</td>
<td>New</td>
<td>Create a new session by opening New Session Properties dialog box.</td>
</tr>
<tr>
<td>![Open]</td>
<td>Open</td>
<td>Open the Sessions dialog box.</td>
</tr>
<tr>
<td>![Disconnect]</td>
<td>Disconnect</td>
<td>Close connection with the current session.</td>
</tr>
<tr>
<td>![Reconnect]</td>
<td>Reconnect</td>
<td>Reconnect with the current tab session.</td>
</tr>
<tr>
<td>![Properties]</td>
<td>Properties</td>
<td>Show current session properties. If the session is not opened, default session properties is displayed.</td>
</tr>
<tr>
<td>![Copy]</td>
<td>Copy</td>
<td>Copy the selected field to clipboard.</td>
</tr>
<tr>
<td>![Paste]</td>
<td>Paste</td>
<td>Paste clipboard contents.</td>
</tr>
<tr>
<td>Button</td>
<td>Name</td>
<td>Description</td>
</tr>
<tr>
<td>----------------</td>
<td>-----------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>![Find]</td>
<td>Find</td>
<td>Open the Find dialog box.</td>
</tr>
<tr>
<td>![Print]</td>
<td>Print</td>
<td>Open the Print dialog box.</td>
</tr>
<tr>
<td>![Color Schemes]</td>
<td>Color Schemes</td>
<td>Select color scheme.</td>
</tr>
<tr>
<td>![Encoding]</td>
<td>Encoding</td>
<td>List encodings available with the output language.</td>
</tr>
<tr>
<td>![Fonts]</td>
<td>Fonts</td>
<td>List available font names and sizes. Fonts for the currently Open the session can be changed. To change the font for each session, select a session font from the Session Properties dialog box.</td>
</tr>
<tr>
<td>![New Terminal]</td>
<td>New Terminal</td>
<td>Open the a new Xshell window. Click this button while a connection is being made to attempt connection using the corresponding session’s connection information.</td>
</tr>
<tr>
<td>![New File Transfer]</td>
<td>New File Transfer</td>
<td>Execute Xftp if Xftp™ is installed. Click this button while a connection is being made to start a New File Transfer session with the corresponding session’s connection information. If Xftp is not installed, the Xshell File Transfer session itself is started.</td>
</tr>
<tr>
<td>![Full Screen]</td>
<td>Full Screen</td>
<td>Convert to full screen mode. Screen changes to general window mode when Alt+Enter is pressed.</td>
</tr>
<tr>
<td>![Lock]</td>
<td>Lock</td>
<td>Convert to screen lock mode. User input is not received until password is entered.</td>
</tr>
<tr>
<td>![Key Mapping]</td>
<td>Key Mapping</td>
<td>Open the Custom Key Mapping dialog box.</td>
</tr>
<tr>
<td>![Highlight Sets]</td>
<td>Highlight Sets</td>
<td>Open the Highlight Sets dialog box.</td>
</tr>
<tr>
<td>![Script]</td>
<td>Script</td>
<td>Start Xshell script file.</td>
</tr>
<tr>
<td>![Start Logging]</td>
<td>Start Logging</td>
<td>Start logging.</td>
</tr>
<tr>
<td>![Stop Logging]</td>
<td>Stop Logging</td>
<td>Stop logging.</td>
</tr>
<tr>
<td>![New Tab Group]</td>
<td>New Tab Group</td>
<td>Opens a new local shell tab in a new tab group. Can be opened to the right, bottom, top, or left.</td>
</tr>
<tr>
<td>![Sort Tabs]</td>
<td>Sort Tabs</td>
<td>Arrange the currently opened tabs horizontally, vertically, or tiled. Or merge already arranged tabs.</td>
</tr>
<tr>
<td>![Options]</td>
<td>Options</td>
<td>Open the Options dialog box.</td>
</tr>
<tr>
<td>![User Key Manager]</td>
<td>User Key Manager</td>
<td>Open the User Keys dialog box.</td>
</tr>
<tr>
<td>![Host Key Manager]</td>
<td>Host Key Manager</td>
<td>Open the Host Keys dialog box.</td>
</tr>
<tr>
<td>![Xagent]</td>
<td>Xagent</td>
<td>Execute Xagent program.</td>
</tr>
<tr>
<td>![Help]</td>
<td>Help</td>
<td>Open the Xshell help.</td>
</tr>
</tbody>
</table>
Address Bar

The address bar grammar is as follows:

```
[protocol://][user[:password]@]hostname[:port][/]
```

The available protocols are *ssh*, *sftp*, *telnet*, *rlogin*, and *serial*. The default protocol is a protocol selected in the default session. Default port numbers by protocol are defined as follows:

- **ssh**: 22
- **sftp**: 22
- **telnet**: 23
- **rlogin**: 513
- **ftp**: 21

A number of examples are given below.

<table>
<thead>
<tr>
<th>Example</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>foobar.com</td>
<td>Connect to foobar.com using the protocol and port number designated in the default session.</td>
</tr>
<tr>
<td>ssh://kay:<a href="mailto:passwd@foobar.com">passwd@foobar.com</a>/</td>
<td>Connect to foobar.com using the SSH protocol. User account is 'kay' and password is 'passwd'. The default port number is used.</td>
</tr>
<tr>
<td>ssh://kay@foobar.com:12345/</td>
<td>Connect to foobar.com port 12345 using the SSH protocol. User account is kay.</td>
</tr>
<tr>
<td>telnet://foobar.com/</td>
<td>Connect to foobar.com via telnet protocol. User account is not designated and connection is made with port 23, the default port.</td>
</tr>
<tr>
<td>rlogin://kay@foobar.com/</td>
<td>Connect to foobar.com using the rlogin protocol. The user account is 'kay' and connection is made with port 513, the default port.</td>
</tr>
<tr>
<td>sftp://kay@foobar.com/</td>
<td>Connect to foobar.com using the SFTP protocol. User account is 'kay' and the default port number is used.</td>
</tr>
</tbody>
</table>
**Xshell Local Command**

**Xshell** provides local commands for advanced users familiar with the terminal environment.

Basically, **Xshell** prompt is displayed on the terminal screen when a remote host is not connected. When a session is connected, press ‘Ctrl+Alt+]’ to exit to local prompt. To return to the remote host mode, enter ‘exit’ or press ‘Ctrl+D’.

The following commands can be used.

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>help</td>
<td>Display commands list on the terminal window.</td>
</tr>
<tr>
<td>?</td>
<td></td>
</tr>
<tr>
<td>new</td>
<td>Open the <strong>New Session Properties</strong> dialog box.</td>
</tr>
<tr>
<td>open the [session]</td>
<td>Connect with the corresponding session when ‘session’ is designated. If a session is not designated, the <strong>Sessions</strong> dialog box is opened.</td>
</tr>
<tr>
<td>edit [session]</td>
<td>Open the <strong>Session Properties</strong> dialog box for the corresponding session if ‘session’ is designated. Open the <strong>Session Properties</strong> dialog box for the default session if ‘session’ is not designated.</td>
</tr>
<tr>
<td>list</td>
<td>Display a list of directories and information about sessions in the current directory.</td>
</tr>
<tr>
<td>cd</td>
<td>Change the current task directory.</td>
</tr>
<tr>
<td>clear</td>
<td>Clear local shell command prompt screen, address bar history, and command history.</td>
</tr>
<tr>
<td>exit</td>
<td>Close <strong>Xshell</strong> session or return to remote host.</td>
</tr>
<tr>
<td>quit</td>
<td></td>
</tr>
<tr>
<td>set</td>
<td>Configure the Xshell environment. Certain settings can be defined in the session properties or options. To view the current configuration, type the set command without any command line options.</td>
</tr>
<tr>
<td>ssh [user@]host [port]</td>
<td>Connect using the SSH protocol.</td>
</tr>
<tr>
<td>sftp [user@]host [port]</td>
<td>Connect using the SFTP protocol.</td>
</tr>
<tr>
<td>telnet [user@]host [port]</td>
<td>Connect using the telnet protocol.</td>
</tr>
<tr>
<td>rlogin [user@]host [port]</td>
<td>Connect using the rlogin protocol.</td>
</tr>
<tr>
<td>ftp [user@]host [port]</td>
<td>Connect using the ftp protocol.</td>
</tr>
<tr>
<td>ipconfig</td>
<td>Execute Windows ipconfig command.</td>
</tr>
<tr>
<td>ping host</td>
<td>Execute Windows ping command.</td>
</tr>
<tr>
<td>tracert host</td>
<td>Show packet path to host.</td>
</tr>
<tr>
<td>netstat</td>
<td>Execute Windows netstat command.</td>
</tr>
<tr>
<td>Command</td>
<td>Description</td>
</tr>
<tr>
<td>---------</td>
<td>---------------------------</td>
</tr>
<tr>
<td>nslookup</td>
<td>Execute Windows nslookup command.</td>
</tr>
</tbody>
</table>
## Xshell Command Line Option

The following are the command line parameter options recognized by Xshell. These parameters can be used when executing Xshell from the Windows console program or other applications.

<table>
<thead>
<tr>
<th>Option, Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>'session file'</td>
<td>Execute the session. 'Session file' can include a path.</td>
</tr>
<tr>
<td>-folder 'session folder'</td>
<td>Execute all folder sessions.</td>
</tr>
<tr>
<td>-url [protocol://][user[:password]@]host[:port]</td>
<td>Connect by directly entering URL, rather than using designated session file. Usable protocols are SSH, SFTP, TELNET, RLOGIN and FTP. When protocol is omitted, use the default protocol designated in the Options dialog box [General] tab. When user and password are omitted, a window for the authentication is displayed. When a connection port is not designated, the connection protocol default port of is used.</td>
</tr>
<tr>
<td>-open</td>
<td>Open the Sessions dialog box.</td>
</tr>
<tr>
<td>-register</td>
<td>Open the a dialog box for product registration.</td>
</tr>
<tr>
<td>-about</td>
<td>Open the Xshell Information dialog box where product version and license information is available.</td>
</tr>
<tr>
<td>-prop 'session file'</td>
<td>Open the Session Properties dialog box. 'Session file' can include a path.</td>
</tr>
<tr>
<td>-create 'session file'</td>
<td>Create a new session.</td>
</tr>
<tr>
<td>-newwin</td>
<td>Open the a new Xshell window.</td>
</tr>
<tr>
<td>-newtab 'tab name'</td>
<td>Create a new tab with 'Tab Name'.</td>
</tr>
</tbody>
</table>

### Example

Execute xdev.xsh session file.
Xshell 'c:\users\user\Documents\ NetSarang Computer\6\Xshell\Sessions\xdev.xsh’

Connect to foobar.com with the default protocol.
Xshell -url foobar.com

Connect to foobar.com with ssh.
Xshell -url ssh://foobar.com
Connect to foobar.com with ssh. User name and password are ‘username’ and ‘deomopassword’ respectively.

Xshell -url ssh://username:demopassword@foobar.com

Connect to foobar.com port 2300 using telnet protocol.

Xshell -url telnet://foobar.com:2300

Connect to foobar.com by executing a new Xshell window.

Xshell -newwin -url foobar.com

Note

If the [Open multiple sessions in a single Xshell window] option is set in the [Advanced] tab of Options dialog box, All parameters with the exception of the ‘-newwin’ are executed in the last Xshell window or a new tab.

The ‘-newwin’ option can be used with other options. A new Xshell window is started with the options.
## SFTP Command

**Xshell** provides commands similar to UNIX/Linux FTP for advanced users who are familiar with terminal environments. Descriptions of each command are as follows. For details, enter 'help' command in the SFTP prompt.

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>get file1 [file2] [file3] ...</code></td>
<td>Download files from the remote host.</td>
</tr>
<tr>
<td><code>put file1 [file2] [file3] ...</code></td>
<td>Upload files to the remote host.</td>
</tr>
<tr>
<td><code>mv path1 path2</code>&lt;br&gt;<code>rename path1 path2</code></td>
<td>Move/rename a file or directory on the remote host.</td>
</tr>
<tr>
<td><code>mkdir directory</code></td>
<td>Create a designated directory on the remote host.</td>
</tr>
<tr>
<td><code>rmdir directory</code></td>
<td>Delete a designated directory from the remote host.</td>
</tr>
<tr>
<td><code>rm file</code></td>
<td>Delete a designated file from the remote host.</td>
</tr>
<tr>
<td><code>pwd</code></td>
<td>Display the working directory of the remote host.</td>
</tr>
<tr>
<td><code>lps</code></td>
<td>Display the working directory of the local host.</td>
</tr>
<tr>
<td><code>cd directory</code></td>
<td>Change remote host working directory.</td>
</tr>
<tr>
<td><code>lcd directory</code></td>
<td>Change local host working directory.</td>
</tr>
<tr>
<td><code>ls [directory]</code></td>
<td>Display remote host files list.</td>
</tr>
<tr>
<td><code>lps [directory]</code></td>
<td>Display local host files list.</td>
</tr>
<tr>
<td><code>explore [directory]</code></td>
<td>View the current (or designated) directory via Windows Explorer.</td>
</tr>
<tr>
<td><code>help [command]</code></td>
<td>Show instructions for using SFTP commands list or designated commands.</td>
</tr>
<tr>
<td><code>bye</code></td>
<td>End SFTP connection.</td>
</tr>
<tr>
<td><code>exit</code></td>
<td></td>
</tr>
<tr>
<td><code>quit</code></td>
<td></td>
</tr>
</tbody>
</table>
Regular Expression

This section provides descriptions of the regular expressions used in the Find dialog box.

**Pattern Match**

<table>
<thead>
<tr>
<th>Pattern</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>.</td>
<td>Any one character except newline character</td>
</tr>
<tr>
<td>[abs]</td>
<td>One character of a, b or c</td>
</tr>
<tr>
<td>[a-zA-z]</td>
<td>One character from a to z</td>
</tr>
<tr>
<td>[^ac]</td>
<td>One character excluding a and c</td>
</tr>
<tr>
<td>(x)</td>
<td>x, x can be a regular expression.</td>
</tr>
<tr>
<td>x*</td>
<td>x is repeated 0 time or more. x can be a regular expression.</td>
</tr>
<tr>
<td>x+</td>
<td>x is repeated 1 time or more. x can be a regular expression.</td>
</tr>
<tr>
<td>x{n,m}</td>
<td>x is repeated n times or more and m times or less. x can be a regular expression.</td>
</tr>
<tr>
<td>x{n}</td>
<td>x is repeated n times exactly. X can be a regular expression.</td>
</tr>
<tr>
<td>x{n,}</td>
<td>x is repeated n times or more. X can be a regular expression.</td>
</tr>
<tr>
<td>x</td>
<td>y</td>
</tr>
<tr>
<td>^</td>
<td>Start of a line</td>
</tr>
<tr>
<td>\A</td>
<td>Start of a line</td>
</tr>
<tr>
<td>$</td>
<td>End of a line</td>
</tr>
<tr>
<td>\z</td>
<td>End of a line</td>
</tr>
<tr>
<td>\Z</td>
<td>End of a line</td>
</tr>
<tr>
<td>&lt;</td>
<td>Start of a word</td>
</tr>
<tr>
<td>\b</td>
<td>Start of a word</td>
</tr>
<tr>
<td>&gt;</td>
<td>End of a word</td>
</tr>
<tr>
<td>\B</td>
<td>End of a word</td>
</tr>
</tbody>
</table>

**The shorthand of character classes**

<table>
<thead>
<tr>
<th>Class</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>\w</td>
<td>Characters comprising a word, as in [a-zA-Z0-9_]</td>
</tr>
<tr>
<td>\W</td>
<td>Characters not consisting a word, as in [^a-zA-Z0-9_]</td>
</tr>
<tr>
<td>\s</td>
<td>Spaces</td>
</tr>
<tr>
<td>\S</td>
<td>Characters excluding spaces</td>
</tr>
<tr>
<td>\d</td>
<td>Numbers, as in [0-9]</td>
</tr>
<tr>
<td>\D</td>
<td>Characters excluding numbers, as in [^0-9]</td>
</tr>
</tbody>
</table>
## POSIX character classes

<table>
<thead>
<tr>
<th>Class</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>[:alnum:]</td>
<td>Letters and numbers, as in [a-zA-Z0-9]</td>
</tr>
<tr>
<td>[:alpha:]</td>
<td>Letters, as in [a-zA-Z]</td>
</tr>
<tr>
<td>[:blank:]</td>
<td>Blanks</td>
</tr>
<tr>
<td>[:cntrl:]</td>
<td>Controls</td>
</tr>
<tr>
<td>[:digit:]</td>
<td>Numbers, as in [0-9]</td>
</tr>
<tr>
<td>[:graph:]</td>
<td>Printable characters (blanks excluded)</td>
</tr>
<tr>
<td>[:lower:]</td>
<td>Small letters, as in [a-z]</td>
</tr>
<tr>
<td>[:print:]</td>
<td>Characters which are not controls</td>
</tr>
<tr>
<td>[:punct:]</td>
<td>Punctuations</td>
</tr>
<tr>
<td>[:space:]</td>
<td>Spaces</td>
</tr>
<tr>
<td>[:upper:]</td>
<td>Capital letters, as in [A-Z]</td>
</tr>
<tr>
<td>[:xdigit:]</td>
<td>Characters used to express a hexadecimal number, as in [0-9a-fA-F]</td>
</tr>
</tbody>
</table>

### Example

<table>
<thead>
<tr>
<th>Expression</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>[0-9]+</td>
<td>Pattern where a number is repeated more than once</td>
</tr>
<tr>
<td>(foo)</td>
<td>(bar)</td>
</tr>
<tr>
<td>.html$</td>
<td>Character string ending with ‘.html’</td>
</tr>
<tr>
<td>^.</td>
<td></td>
</tr>
</tbody>
</table>
## Pre-defined Shortcut Key

The list below shows descriptions of shortcut keys defined in **Xshell**.

<table>
<thead>
<tr>
<th>Shortcut Key</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Alt + 1~9</td>
<td>Move session tab</td>
</tr>
<tr>
<td>Alt + A</td>
<td>[View] Always on Top</td>
</tr>
<tr>
<td>Alt + C</td>
<td>Same as Disconnect in the File menu</td>
</tr>
<tr>
<td>Alt + D</td>
<td>Move keyboard focus to address bar</td>
</tr>
<tr>
<td>Alt + Enter</td>
<td>Convert to full screen mode</td>
</tr>
<tr>
<td>Alt + I</td>
<td>[Edit] Move to Compose Bar</td>
</tr>
<tr>
<td>Alt + Insert</td>
<td>[Edit] Paste Selection</td>
</tr>
<tr>
<td>Alt + J</td>
<td>[Edit] Move to Compose Pane</td>
</tr>
<tr>
<td>Alt + L</td>
<td>Change layout</td>
</tr>
<tr>
<td>Alt + Left</td>
<td>Same as Previous in the Window menu</td>
</tr>
<tr>
<td>Alt + M</td>
<td>[Edit] Move to Session Manager</td>
</tr>
<tr>
<td>Alt + N</td>
<td>Same as New in the File menu</td>
</tr>
<tr>
<td>Alt + O</td>
<td>Same as Open the in the File menu</td>
</tr>
<tr>
<td>Alt + P</td>
<td>[File] Session Properties</td>
</tr>
<tr>
<td>Alt + R</td>
<td>[View] Transparent</td>
</tr>
<tr>
<td>Alt + Right</td>
<td>Same as Next in the Window menu</td>
</tr>
<tr>
<td>Alt + S</td>
<td>[View] Simple Layout Mode</td>
</tr>
<tr>
<td>Ctrl + Alt + ]</td>
<td>Exit to local prompt during connection</td>
</tr>
<tr>
<td>Ctrl + Alt + F</td>
<td>Same as New File Transfer in the Window menu</td>
</tr>
<tr>
<td>Ctrl + Alt + N</td>
<td>[Window] New Window</td>
</tr>
<tr>
<td>Ctrl + Alt + T</td>
<td>Same as New Terminal in the Window menu</td>
</tr>
<tr>
<td>Ctrl + F1-F12</td>
<td>[Quick Command] Command #01~#12</td>
</tr>
<tr>
<td>Ctrl + Insert</td>
<td>[Edit] Copy</td>
</tr>
<tr>
<td>Ctrl + Pause</td>
<td>[Edit] Send Break</td>
</tr>
<tr>
<td>Ctrl + Shift + A</td>
<td>[Edit] Clear Screen and Scrollback Buffer</td>
</tr>
<tr>
<td>Ctrl + Shift + Alt + [</td>
<td>[View] Decrease Font Size</td>
</tr>
<tr>
<td>Ctrl + Shift + Alt + ]</td>
<td>[View] Increase Font Size</td>
</tr>
<tr>
<td>Ctrl + Shift + B</td>
<td>[Edit] Clear Scrollback Buffer</td>
</tr>
<tr>
<td>Ctrl + Shift + F4</td>
<td>[Tab] Close</td>
</tr>
<tr>
<td>Shortcut Key</td>
<td>Description</td>
</tr>
<tr>
<td>----------------------</td>
<td>--------------------------------------------------</td>
</tr>
<tr>
<td>Ctrl + Shift + L</td>
<td>[Edit] Clear Screen</td>
</tr>
<tr>
<td>Ctrl + Shift + R</td>
<td>[Connection] Reconnect</td>
</tr>
<tr>
<td>Ctrl + Shift + T</td>
<td>[View] Session Tab</td>
</tr>
<tr>
<td>Ctrl + Shift + Tab</td>
<td>[Tab] Move to previous session</td>
</tr>
<tr>
<td>Ctrl + Tab</td>
<td>Move to the next session tab in a single Xshell window</td>
</tr>
<tr>
<td>Pause</td>
<td>[Edit] Send Break</td>
</tr>
<tr>
<td>Shift + Alt + Enter</td>
<td>[View] Multipane Full Screen</td>
</tr>
<tr>
<td>Shift + Alt + L</td>
<td>[View] Choose Layout (Up)</td>
</tr>
<tr>
<td>Shift + Alt + N</td>
<td>[Tab] Open New Tab</td>
</tr>
<tr>
<td>Shift + Alt + T</td>
<td>[Connection] Duplicate Current Session</td>
</tr>
<tr>
<td>Shift + Down Arrow</td>
<td>Downward scroll</td>
</tr>
<tr>
<td>Shift + End</td>
<td>To end</td>
</tr>
<tr>
<td>Shift + Home</td>
<td>To top</td>
</tr>
<tr>
<td>Shift + Insert</td>
<td>[Edit] Paste</td>
</tr>
<tr>
<td>Shift + PgDn</td>
<td>Page down</td>
</tr>
<tr>
<td>Shift + PgUp</td>
<td>Page up</td>
</tr>
<tr>
<td>Shift + Tab</td>
<td>Move to the recently used session tab in a single Xshell window</td>
</tr>
<tr>
<td>Shift + Up Arrow</td>
<td>Upward scroll</td>
</tr>
</tbody>
</table>

**Note**

Use the standard [Key Mapping] button to change shortcut keys. In the Custom Key Mapping dialog box, change shortcut key combinations and allocate key operations such as menu, send character string, execute script, and execute program.
Index

Address Bar, 25, 72
Appearance, 18
Authentication, 11
Color Scheme, 42
Command Line Option, 75
Connection, 11
Copy and Paste, 40
Create User Key, 29
Cursor Change, 43
Encoding, 47
File Transfer Using SFTP, 57
File Transfer Using ZMODEM, 58
Find, 41
   Regular Expression, 41
Font, 41
   Bold Text, 42
Host Key, 31
Host Keys Dialog Box, 31
Install and Uninstall, 4
Keep alive, 15
Keyboard, 16
Keypad Mode, 48
Layout, 48
Local command, 73
Local prompt, 73
Local Prompt, 25
Logging, 22
Login Prompts, 12
Login Scripts, 12
Margins, 19
Minimize to Notification Area, 44
Multiple Sessions, 45
Print, 63
Proxy, 15
Proxy Setting, 28
Public Key User Authentication, 29
Quick Command Set, 20
Quick Command Sets, 45
Regular Expression, 78
Revert to local shell, 44
RLOGIN, 14
Script, 66
Scroll Buffer, 47
SERIAL, 14
SERIAL Connection, 26
Session, 9
   Copy, 9
   Copy session file, 10
   Create, 9
   Create folder, 10
   Default session, 10
   Delete, 10
   Edit, 9
   Export, 23
   Import, 24
   Rename, 9
   Shortcut, 10
Session Folder, 51
Session Logging, 61
Session Properties, 10
   Appearance, 18
   Authentication, 11
   Connection, 11
   Logging, 22
   Login Prompts, 12
   Login Scripts, 12
   Margins, 19
   Proxy, 15
   Quick Command Set, 20
   RLOGIN, 14
   SERIAL, 14
   SSH, 13
   Security, 13
   SFTP, 14

82 | Index
Tunneling, 14
TELNET, 14
Terminal, 15
Advanced, 17
Keyboard, 16
VT Mode, 17
Tracing, 20
ZMODEM, 23
Session Tracing, 61
Sessions dialog box, 25
SFTP, 14
SFTP Command, 77
Shortcut Key, 80
SSH, 13
SSH Security Warning, 31
Standard Buttons, 70

Startup Sessions, 51
TELNET, 14
Terminal, 15
Terminal Type, 48
Tracing, 20
Tunneling, 14, 36
Instant Tunneling, 38
SOCKS4/5 Dynamic Port Forwarding, 38
TCP/IP Port Forwarding, 36
X11 Forwarding, 37
User Keys Dialog Box, 30
VT Mode, 17
Xagent, 64
ZMODEM, 23